[B2G][Settings][Firefox Accounts]No confirmation request when user signs out of firefox account

RESOLVED DUPLICATE of bug 1016496

Status

Firefox OS
FxA
RESOLVED DUPLICATE of bug 1016496
4 years ago
4 years ago

People

(Reporter: Ross Kuhlman (rkuhlman@qanalydocs.com), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.0-daily-testing])

Attachments

(1 attachment)

Created attachment 8442186 [details]
FirefoxAccount.txt

The Firefox Accounts settings page has a sign out button. When tapped, the user is automatically signed out of their profile and returned to settings menu. There should be a pop up asking the user to confirm that they wish to sign out of their profile. Anyone who accidentally taps the button will be automatically signed out.

Repro Steps:
1) Update a Flame to BuildID: 20140618000202
2) Launch Settings >> Firefox Accounts
3) Sign into a valid Firefox account
4) On the Firefox Accounts Settings screen, tap the sign out button

Actual:
User is immediately signed out of profile

Expected:
A pop up appears asking the user to confirm that they wish to sign out

v2.0 Environmental Variables:
Device: Flame v2.0 MOZ
BuildID: 20140618000202
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 55679dc2e72b
Version: 32.0a2
Firmware Version: v121-2


Notes:

Repro frequency: 100%
See attached: logcat
adding qawanted to determine if issue is also affecting 1.4 and 2.1(Master)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Whiteboard: [2.0-daily-testing]
QA-Wanted for Branch/Device checks
Flags: needinfo?(jmitchell)
Component: Gaia::Settings → FxA
Issue DOES occur on Flame 2.1, Buri 2.1, Open C 2.1, Buri 2.0, and Open C 2.0


Environmental Variables:
Device: Flame 2.1
Build ID: 20140618040513
Gaia: 431aed0a7c7560c6eacd35ea69aa0a7a4ebe72c7
Gecko: 37f08ddaea48
Version: 33.0a1  
Firmware Version: v121-2

Environmental Variables:
Device: Buri 2.1
Build ID: 20140618040513
Gaia: 431aed0a7c7560c6eacd35ea69aa0a7a4ebe72c7
Gecko: 37f08ddaea48
Version: 33.0a1  
Firmware Version: v1.2device.cfg

Environmental Variables:
Device: Open_C 2.1
Build ID: 20140618040513
Gaia: 431aed0a7c7560c6eacd35ea69aa0a7a4ebe72c7
Gecko: 37f08ddaea48
Version: 33.0a1  
Firmware Version: P821A10V1.0.0B06_LOG_DL

Environmental Variables:
Device: Buri 2.0
Build ID: 20140618000202
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 55679dc2e72b
Version: 32.0a2 (2.0) 
Firmware Version: v1.2device.cfg

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140618000202
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 55679dc2e72b
Version: 32.0a2 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL


Actual Result: User is immediately signed out of profile

Firefox Account sign-in is not present on 1.4, unable to test on 1.4 builds
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Filed in GitHub as https://github.com/mozilla/fxa-content-server/issues/1272

Note that the GitHub issue would address the about:accounts and accounts.firefox.com on Desktop.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1016496
You need to log in before you can comment on or make changes to this bug.