[SCR] [Rocketbar] icon to show search provider + way to select and change the search provider from that icon

RESOLVED DUPLICATE of bug 1039184

Status

Firefox OS
Gaia::Search
--
enhancement
RESOLVED DUPLICATE of bug 1039184
4 years ago
3 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 wontfix, b2g-v2.1 affected)

Details

Software Change Request [SCR]:
1. have an icon that shows the search provider being used ( from the settings )
2. a way to select that icon and change to a different listed search provider

Currently there's no way to tell from the Rocketbar to see which search provider is being used (unlike the desktop browser's quick search ) nor a quick way of changing it rather than having to go to the settings.
Flags: needinfo?(firefoxos-ux-bugzilla)
Change request for future version.  Would prefer if we released with this in 2.0, I understand if it gets backlogged for a later release.
status-b2g-v2.0: --- → affected
Wasn't this originally in the UX spec? I thought this was called out in the spec to my understanding.

Updated

4 years ago
Blocks: 1017954
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]

Updated

4 years ago
No longer blocks: 1017954

Comment 3

4 years ago
I share Jason's memory. Flagging Omega and/or Jenny to confirm.
Flags: needinfo?(ofeng)
Flags: needinfo?(jelee)
Flags: needinfo?(firefoxos-ux-bugzilla)
Yes, it's defined in the Rocket Bar UX spec.
Hi Francis, could you point out where the UX spec is, thanks!
Flags: needinfo?(ofeng)
Flags: needinfo?(jelee)
Flags: needinfo?(fdjabri)
This was cut from 2.0 (it required search suggestions from alternative providers implemented)
Yes, we will implement this when the search suggestions are also configurable by the search provider.
Flags: needinfo?(fdjabri)
should this be closed as dup of bug 1039184?
status-b2g-v2.0: affected → wontfix
status-b2g-v2.1: --- → affected
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1039184
You need to log in before you can comment on or make changes to this bug.