[B2G][2.0][Flame][Vertical Homescreen] Smart Collection loads 10 items only

RESOLVED DUPLICATE of bug 1027003

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1027003
4 years ago
4 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-flame-test-run-2])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8442344 [details]
SmartCollectionOnly10Icons.zip

Description: 
Smart Collections is not displayed as 1.4. Each Smart Collection loads 10 items only, and does not display any relevant certified apps.

Repro Steps:
1) Update a Flame to 20140618000202.
2) Long press on any empty space on the vertical homescreen.
3) Add Smart Collections > Select any category > 'OK' > open the newly created smart collection.
4) Verify that the smart collection displays as 1.4.

Actual:
The smart collection only loads 10 items.

Expected:
The smart collection loads continuously as the user scrolls down the page, and displays relevant certified apps at the top.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140618000202
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 55679dc2e72b
Version: 32.0a2 (2.0) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/13292/
See attached: screenshots, logcat
(Logcat is used on Open C. See https://bugzilla.mozilla.org/show_bug.cgi?id=1010993)
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
No longer depends on: 1026616
Flags: needinfo?(ktucker)
(Reporter)

Updated

4 years ago
No longer blocks: 1017954
This issue DOES reproduce on Flame 2.1, Buri 2.1, Open C 2.1, Flame 2.0, Buri 2.0, and Open C 2.0

Flame 2.1

Environmental Variables:
Device: Flame Master
Build ID: 20140618040513
Gaia: 431aed0a7c7560c6eacd35ea69aa0a7a4ebe72c7
Gecko: 37f08ddaea48
Version: 33.0a1 (Master) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Open_C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140618040513
Gaia: 431aed0a7c7560c6eacd35ea69aa0a7a4ebe72c7
Gecko: 37f08ddaea48
Version: 33.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140618073003
Gaia: 336c30b6147cdd9122ad0b2bbffb81eb869a9ec2
Gecko: 1cea544c74c5
Version: 33.0a1 (Master) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140618063014
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 883d156210cf
Version: 32.0a2 (2.0) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140618000202
Gaia: 83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec
Gecko: 55679dc2e72b
Version: 32.0a2 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Smart collections added to the homescreen will only have 10 items in them
_________________________________________________________________________________________

This issue does NOT reproduce on Flame 1.4, Buri 1.4 or Open C 1.4

Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140618063004
Gaia: fc74015d26bcbc3e31a45d34cb65777112a35982
Gecko: fab72d8aa2e0
Version: 30.0 (1.4) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140618000203
Gaia: 3bdd037ec1a11abebe16a5d7f6ff0d863e80bc07
Gecko: 523491fa3339
Version: 30.0 (1.4) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Open_C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140618000203
Gaia: 3bdd037ec1a11abebe16a5d7f6ff0d863e80bc07
Gecko: 523491fa3339
Version: 30.0 (1.4) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

All the appropriate items are loaded into each smart collection
Collections are coming soon, and this will happen once bug 1027003 is resolved.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1027003
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.