Closed Bug 1027307 Opened 7 years ago Closed 7 years ago

[B2G][Settings][Firefox Accounts]Resend verification email button does not function properly, new verification email never appears in inbox

Categories

(Firefox OS Graveyard :: FxA, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1004251

People

(Reporter: rkuhlman, Unassigned)

Details

Attachments

(1 file)

When creating a new Firefox account, the new user must verify the account via an email sent to their inbox. In case the verification email is not properly recieved, the menu displays a 'resend' button. The device tells the user that a new email is being sent when this button is pressed, but the email is never recieved.

Repro Steps:
1) Update a Flame to BuildID: 20140618040513
2) Launch Settings >> Firefox Accounts
3) Enter a valid email address that is not associated to any firefox account
4) Enter an age over 13 and create a password when prompted
5) Proceed to firefox account confirmation page (by now you should have the confirmation email in your inbox. ignore or delete this email)
6) Tap the 'Resend' button

Actual:
Pop-up inorms user that another confirmation email has been sent. No new confirmation emails are ever recieved in inbox

Expected:
New confirmation email is sent to email address when user requests resend

Master M/C Environmental Variables:
Device: Flame Master M/C MOZ
BuildID: 20140618040513
Gaia: 431aed0a7c7560c6eacd35ea69aa0a7a4ebe72c7
Gecko: 37f08ddaea48
Version: 33.0a1
Firmware Version: v121-2


Notes:
first confirmation email appears in inbox almost immediately. 
"Resent" emails have still not appeared even 90 minutes later


Repro frequency: 100%
See attached: logcat
adding qawanted tag to determine if issue reproduces in v1.4 and v2.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Flags: needinfo?(jmitchell)
Component: Gaia::Settings → FxA
Hi,

Just as a courtesy, it would be super helpful if you could maybe scan existing issues before continuing to file duplicate after duplicate.

As mentioned in the other (fixed and merged) bug about this issue[1], you cannot resend within 15 minutes of creating an account. I am guessing that's the actual issue here. Feel free to reopen if I'm in error.

Cheers,

Jared

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1004251#c34
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(rkuhlman)
Resolution: --- → DUPLICATE
Duplicate of bug: 1004251
Keywords: qawanted
Hello,
I scan the database several times before each bug I submit, but sometimes mistakes are made. As a smoketester, I am on a serious time restriction, and the 5+ minute wait for searches to populate with results means that I simply do not have enough time to search for every possible permutation of different terms that may be used in a title or comment. Similarly many bugs are written with vague or jargon-heavy titles that are useful for devs, but very difficult for anyone else who is unfamiliar with internal terminolgy to search for.
Flags: needinfo?(rkuhlman)
You're right, it's not reasonable to expect people external to the project to know how to find and dedupe bugs. I'm sorry!

So, let me try again: thanks for your hard work flushing out bugs as we're hitting the 2.0 deadline. It's really great to have the help, it's much needed and appreciated. File as many dupes as you can ^_^

Have a nice weekend,

Jared
Flags: needinfo?(rkuhlman)
Hello Jared,

I did not intend to blame anyone else for my shortcomings, I merely wished to provide an explanation for why I did not find the original bug.

I will do my best to find any and all possible dupes before submitting bugs in the future.

Thank you,
Ross
Flags: needinfo?(rkuhlman)
QA Whiteboard: [QAnalyst-Triage?]
You need to log in before you can comment on or make changes to this bug.