Closed Bug 1027346 Opened 5 years ago Closed 5 years ago

Progressive Paint is incorrectly hit during Vertical homescreen edit

Categories

(Core :: Graphics: Layers, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1021085

People

(Reporter: BenWa, Unassigned)

References

Details

Attachments

(1 file)

STR:
1) Click and hold an icon on the Vertical. You should enter the 'Edit' mode.
2) Move the icon around
3) Release the icon

During the release you might get a flicker caused by progressive draw.

Progressive draw should not be triggered when we're not scrolling. We have code in place to avoid progressive draw on Fennec of content we've already validated because it causes this flicker but it's not applied here.
Here's a profile showing the bug:
http://people.mozilla.org/~bgirard/cleopatra/#report=04102901652b7363c3969fefaec593230204e870

The problem occurs at 97567ms in the profile (near the end). Once the QR code are decode the video should sync along side.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1021085
You need to log in before you can comment on or make changes to this bug.