Closed Bug 1027369 Opened 7 years ago Closed 3 years ago

[Gallery] Redrawing of Screen after app 2 app edge swipe is slow

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
tracking-b2g backlog

People

(Reporter: rmacdonald, Unassigned)

References

()

Details

(Whiteboard: [systemsfe][perf-reviewed])

Steps to Reproduce

Launch a few apps. 
Launch gallery. 
Hold the camera in landscape. 
Swipe from the left edge to return to an app that is in portrait. 
Wait for the portrait app to load.
Then activate a swipe from the right edge to return to gallery.

Behaviour:
Screen initially shows in landscape then it loads, then flashes and redraws in portrait over the course of a couple of seconds.

Expected Behaviour:
Screen should be properly rendered when the edge swipe overlay is removed.
We need a video of the bug here.
Component: Gaia::Gallery → Gaia::System::Window Mgmt
Keywords: qawanted
Whiteboard: [systemsfe]
QA Contact: jsmith
QA Contact: ddixon
Attached video in URL field.  

Environmental Variables:
Device: Flame 2.1 - Master
Build ID: 20140619071512
Gaia: 135a13ea0ee333314b6a12cb19f18617308a3b46
Gecko: 6fe58da83ef8
Version: 33.0a1 (2.1 - Master)
Firmware Version: v121-2
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA-Wanted for Device/Branch checks
Flags: needinfo?(jmitchell)
BURI

Feature is not implemented in latest 1.3,1.4 Buri build.

Issue DOES occur in Buri 2.0

Device: Buri 2.0
Build ID: 20140609072940
Gaia: d283b742a12ac43ec087f45b02d3817cf7ddab69
Gecko: 8bbb61b80df4
Version: 32.0a1 (2.0)
Firmware Version: v1.2device.cfg

Issue DOES occur here in latest Buri 2.1 

Device: Buri 2.1 - Master
Build ID: 20140619074016
Gaia: 135a13ea0ee333314b6a12cb19f18617308a3b46
Gecko: ad11457bae17
Version: 33.0a1 (2.1 - Master)
Firmware Version: v1.2device.cfg

FLAME 

Feature is not implemented in latest 1.4 Flame build. 

Feature is not implemented in v10G-2 base

Device: Flame 1.3
Build ID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3)
Firmware Version: v10G-2

Feature is not implemented in v10F-3 Flame base.

Device: Flame 1.3
Build ID: 20140505215459
Gaia: ec462dc62979dae593b4ad96ac3851ccbafe1813
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3)
Firmware Version: v10F-3

Feature is not implemented in v121-2 Flame base.

Device: Flame 1.3
Build ID: 20140610200025
Gaia: e106a3f4a14eb8d4e10348efac7ae6dea2c24657
Gecko: b637b0677e15318dcce703f0358b397e09b018af
Version: 28.0 (1.3)
Firmware Version: v121-2

Issue DOES occur in 2.0 Flame. 

Device: Buri 2.0
Build ID: 20140609072940
Gaia: d283b742a12ac43ec087f45b02d3817cf7ddab69
Gecko: 8bbb61b80df4
Version: 32.0a1 (2.0)
Firmware Version: v1.2device.cfg

Issue DOES occur in latest 2.1 Flame build.

Device: Flame 2.1 - Master
Build ID: 20140619080214
Gaia: 135a13ea0ee333314b6a12cb19f18617308a3b46
Gecko: ea703db56bcf
Version: 33.0a1 (2.1 - Master)
Firmware Version: v121-2


OPEN_C

Feature not implemented in latest 1.3, 1.4 builds.

Issue DOES occur in latest 2.0 Open_C

Device: Open_C 2.0
Build ID: 20140609074621
Gaia: d283b742a12ac43ec087f45b02d3817cf7ddab69
Gecko: 68ac46c1b1f7
Version: 32.0a1 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL

Issue DOES occur in latest 2.1 Open_C 

Device: Open_C 2.1 - Master
Build ID: 20140619080214
Gaia: 135a13ea0ee333314b6a12cb19f18617308a3b46
Gecko: ea703db56bcf
Version: 33.0a1 (2.1 - Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
Flags: needinfo?(jmitchell)
Issues always repros or is not implemented so not a regression.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
I don't think the edge gestures interaction in an up or down motion is going to be normal for a user (i.e. edge case). The transition is ugly, but the functionality works. On that regard, this is not a blocker, since this is an edge case & does not have critical functional impact.
blocking-b2g: 2.0? → backlog
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Whiteboard: [systemsfe] → [systemsfe][perf-reviewed]
Strange. This should be fixed by bug 992085. Etienne?
Flags: needinfo?(etienne)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #7)
> Strange. This should be fixed by bug 992085. Etienne?

I can still reproduce it :/
It's on my list of bugs to look at for a rainy day.
Flags: needinfo?(etienne)
Priority: -- → P2
blocking-b2g: backlog → ---
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.