Closed Bug 10274 Opened 22 years ago Closed 22 years ago

NECKO: linking to empty stylesheet causes error

Categories

(Core :: Networking, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: dbaron, Assigned: rpotts)

Details

Attachments

(1 file)

Linking to an empty stylesheet (0 bytes) causes the error:

CSSLoaderImpl::DidLoadStyle: Load of URL
'http://www.fas.harvard.edu/~dbaron/tests/empty.css' failed.  Error code: 0

and prevents other stylesheets from loading.  Test case to be attached.
The test case should show light text on a dark background.
Assignee: peterl → gagan
Component: Style System → Networking-Core
Apparently a Linux only problem in networking code.
QA Contact: chrisd → paulmac
Summary: linking to empty stylesheet causes error → NECKO: linking to empty stylesheet causes error
Pl. verify with Necko.
Component: Networking-Core → Necko
Target Milestone: M9
Assignee: gagan → rpotts
Rick: something to do with zero length cases?
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
this looks good now on linux/window. White text with green background.
On Linux 1999-08-13-08-M9, I'm still seeing the error, but the other stylesheets
are loading.  I'm not sure if this merits reopening the bug, but I'm reopening
it since my comments will otherwise probably be ignored :-(.  Feel free to
re-resolve and verify it if you think it isn't a problem.

(In theory, these errors might cause problems with alternate stylesheet
selection or something.  Maybe not.  cc:ing peterl for his opinion.)

Clearing target milestone of M9, since M9 is right about now.
Status: VERIFIED → REOPENED
Target Milestone: M9
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen of this bug.

I think we can release not for M9...paulmac please add info to Release Note
bug...http://bugzilla.mozilla.org/show_bug.cgi?id=11352

rickg, if you disagree, please move back to M9.
Clearing FIXED resolution due to reopen of this bug.

I think we can release not for M9...paulmac please add info to Release Note
bug...http://bugzilla.mozilla.org/show_bug.cgi?id=11352

rickg, if you disagree, please move back to M9.
Status: REOPENED → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → FIXED
This is fixed, the fact that the console error message still gets displayed is
irrelevant, it just means that there's no stylesheet data to parse (since it's 0
length).
Status: RESOLVED → VERIFIED
marking verified, per peter's comments
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.