Mozilla crashes when clicking on file

VERIFIED FIXED

Status

()

Core
Plug-ins
--
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Francisco León, Assigned: serge (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20011001
BuildID:    2001100101

Go to url, click on any file, like mozilla-devel.
Mozilla crashes with no talkback or console output

Reproducible: Always
Steps to Reproduce:
1.Go to url
2.Click on any rpm file


Actual Results:  Crash

Expected Results:  Window prompting to save

Plugins installed: java, flash, real audio
I downloaded another program in rpm from another webpage and no crash

Comment 1

17 years ago
Works For Me

2001100108 on Linux
(Reporter)

Comment 2

17 years ago
2001100408 still crashes on me.
Perhaps this is because in the last 3 builds i have used, all 3 have been red
hat 7.x rpm's, and they may be causing crashes on my mandrake 8.1 box
Maybe i will try the precompiled tar.gz later

Comment 3

17 years ago
adding blizzard.
What happens if you go to a site that has a real audio file on it?  The .rpm
extension is often mis-tranlsated into audio/x-pn-realaudio.
(Reporter)

Comment 5

17 years ago
Most real audio stuff i find, are in "ram" format, not rpm itself, so i dont
have this problem (if you find something with real rpm, tell me to test)
But that's not the issue.
The issue is that mozilla.org is sending some http header that is making mozilla
crash. What else could explain that i can click on other rpm files in other web
servers and get a save dialog?
Example: go to galeon.sourceforge.net, click on download, get galeon. You should
be taken to the sourceforge download repository. Pick out any rpm file, and
click on it. You should get a save dialog.
(Reporter)

Comment 6

17 years ago
Created attachment 52543 [details]
Nothing like debuggin'
(Reporter)

Comment 7

17 years ago
Lots of things messing around. Glibc (2.2.4) and maybe the own realaudio plugin
are giving trouble.
Using mandrake 8.1 and build 2001100808

Now, why is mozilla.org the only site giving me trouble? Maybe the httpd is
sending the wrong header and real audio is getting called when it should not 
(Reporter)

Comment 8

17 years ago
When erasing both real player libs from the plugins dir, i dont get the crash
anymore, but other sites dont give me trouble even with the plugin installed

Comment 9

17 years ago
->plugins
Assignee: asa → av
Component: Browser-General → Plug-ins
QA Contact: doronr → shrir

Comment 10

17 years ago
Francisco, other sites which do not give you a trouble -- do they have real .rpm 
files? My guess is that these files here are not, they just have .rpm extension, 
do not contain actual RealPlayer content. Maybe the plugin gets screwed by this.
(Reporter)

Comment 11

17 years ago
the rpms on the mozilla http site are the same type of file that the rpms found
on the galeon website.

If there is any problem, it must be in the http header the 2 websites send

Comment 12

17 years ago
WFM on Linux RH 7.1 with CVS trunk build from 20011221  for Flash plugin 5.0 r47
and java plugin (jre1.3.1_01)
(Reporter)

Comment 13

17 years ago
install real audio plugin and watch it sink

Comment 14

17 years ago
I think that this is INVALID bug. I found out the content-type of 
*rpm files given by http server of ftp.mozilla.org: audio/x-pn-realaudio-plugin.
I did it by means of 'telnet' program.

So Mozilla works absolutely correctly because it founds correct
plugin for this content type. So this is NOT mozilla bug but
this is error of configuration of http server of ftp.mozilla.org. I propose
to close this bug as INVALID. The same situation was in bug #109681.
(Reporter)

Comment 15

17 years ago
what did you think "on mozilla site it crashes, in others it does not?"
yes, we know it's a server flaw, but should mozilla crash anyway? I think not

Comment 16

17 years ago
Since this if an ftp url, this could have been caused by bug #116170.
ftp stites were crashing mozilla. This is fixed now.

Test this on a trunk build and see if it crahses on you.
If not then this bug has been fixed.

--pete

Comment 17

17 years ago
I couldn't reproduce this (browser doesn't crash)
with trunk build (CVS sources from 20020113). Patch for #116170 has been
already checked into these sources.

Comment 18

17 years ago
I'd say bug owner should mark this WORKSFORME


--pete
(Reporter)

Comment 19

17 years ago
I will mark this when i see the patch make it on the nightlies. Somehow it 
still has not been checked

Comment 20

17 years ago
--- Mass reassigning Unix bugs to serge ---
Assignee: av → serge
(Assignee)

Comment 21

17 years ago
I cannot reproduce the crash using 2002.01.18 linux debug build.
Francisco, are you still seeing the problem here?
(Reporter)

Comment 22

17 years ago
same build
-with no real plugin: download window appears. File is sniffed as a real audio 
file
-with plugin installed: mozilla thinks it's a real audio file, and tries to 
open the file with the plugin, but no longer crashes

So, marking fixed. Please contact whoever in the mozilla organization maintains 
the httpd so they can fix the wrong file header as shown by #comment 14
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 23

17 years ago
looking good, no crash.(0227 trunk)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.