Redirecting emails is getting it completely wrong

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Mitra Ardron, Unassigned)

Tracking

({regression})

31 Branch
x86
Mac OS X
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB31?])

(Reporter)

Description

4 years ago
A new feature has appeared in TB31.0 which second guesses email addresses e.g. I enter part of an email address such as  xxx@lumeter and I see it replaced with
 
xxx@lumeter >> Xxx Yyyy <xxx.yyyy@gmail.com>

I don't know where it gets this redirect, but it looks something like its taking xxx@yyy.com, finding it in my OSX address book; then either getting the other email address in that record, or using the name to look in a Facebook record and using the email from this.

This is completely wrong - if a user types an explicit email address (anything with an "@" in it) then TB should NOT be overriding it with a different email address.

Its really hard to get around this, I haven't figured out the algorithm to get it to use the email I want 

Note some weird other UI changes in this version make it harder to diagnose for example there used to be a drop-down with all matching addresses, but it doesn't always appear anymore - and when it does it often appears on top of what you are typing.
(Reporter)

Updated

4 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1009469
(Reporter)

Comment 2

4 years ago
I don't think this is a duplicate of Bug #1009469 which is about the broken UI around autocomplete. 

This bug is about it picking the wrong auto-completion. 

Shouldn't this be a "DependsON" for Bug #1009469 instead ?

Comment 3

4 years ago
Yes, some other bug made changes to autocomplete so we search more fields than we used to.
So the other email address is found in some other field (notes maybe?) of that user?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

4 years ago
Magnus - I don't think that is what was happening, There was an record imported from OSX with both addresses, and a "Collected Address" record with one of them. I deleted the COllected Address one and dont seem to be able to recreate the bug (it was hard to see exactly what was happening because of the UI bug in $1009469. 

Next time it happens I'll do a detailed report - and if someone is interested in fixing it then I won't delete the offending records so we can look deeper.

Updated

4 years ago
Blocks: 1008543

Comment 5

4 years ago
Mitra, is beta 3 all better?
Flags: needinfo?(mitra_lists)
Whiteboard: [regression:TB31?]
(Reporter)

Comment 6

4 years ago
Hi Wayne - sorry, I'm not clear how to tell if I've got Beta3 - I'm on the Beta Update Channel, running 31.0 and "About Thunderbird" says up to date.   
I'm not seeing it currently, and I notice that Tabbing out of the autocomplete now correctly selects the one that is highlighted AND if I see the >> and hit tab then it correctly gets rid of the >>. So I don't have a test case that fails any more.
Flags: needinfo?(mitra_lists)

Comment 7

4 years ago
Thanks. THen that's good enough for WFM
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.