Lists with Headings applied do not create new list items properly

VERIFIED FIXED in mozilla0.9.7

Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: TucsonTester2, Assigned: mozeditor)

Tracking

Trunk
mozilla0.9.7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE; fixinhand; need r=,sr=)

(Reporter)

Description

17 years ago
Build ID: 20011001

Composer does not let you properly exit out of a list if a heading paragraph
style is chosen.

Reproducible: Always

Steps to reproduce:
1.Open Composer
2.Type in a few lines of text
3.Click Edit -> select all
4.Choose Heading 1 from the paragraph styles drop-down menu
5.Click at the end of the last line of the list
6.Type some text
7.Hit enter again

Actual Results:
The first return makes a line underneath the heading 1 line, but this is not a
new list line.  The second return makes a new list line. A third return will
exit the list.

Expect Results:
I would expect that hitting return would make a new list line.  I would expect
that the new list line would be body text.
(Reporter)

Updated

17 years ago
Summary: List with Heading applied do not create new lines properly → Lists with Headings applied do not create new lines properly

Comment 1

17 years ago
Confirmed on Mac OSX using build 20011003, and Win 2k using build 20011002.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
EDITORBASE
Assignee: syd → cmanske
Whiteboard: EDITORBASE

Comment 3

17 years ago
What list? I see nothing in the "Steps to reproduce" about creating a list.
Insufficient bug description.

Comment 4

17 years ago
Steps to reproduce:
1.Open Composer
2.Click on the numbered list button on the toolbar, and type in a few lines of
list items.
3.Click Edit -> select all
4.Choose Heading 1 from the paragraph styles drop-down menu
5.Click at the end of the last line of the list
6.Type some text
7.Hit enter again

Actual Results:
The first return makes a line underneath the heading 1 line, but this is not a
new list line.  The second return makes a new list line. A third return will
exit the list.

Expect Results:
I would expect that hitting return would make a new list line.  I would expect
that the new list line would be body text.


Comment 5

17 years ago
editor core bug
Assignee: cmanske → jfrancis
Component: Editor: Composer → Editor: Core
Summary: Lists with Headings applied do not create new lines properly → Lists with Headings applied do not create new list items properly
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 6

17 years ago
*** Bug 102759 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

17 years ago
Although this is a seperate bug, the fix is in the patch for bug 98351.
Whiteboard: EDITORBASE → EDITORBASE; fixinhand; need r=,sr=
(Assignee)

Comment 8

17 years ago
*** Bug 74051 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

17 years ago
097
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 10

17 years ago
fix checked in on trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
Verified on build 2001112703.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.