[Vertical Homescreen] [Smart collections] Context menu is displayed long pressing empty spaces

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Everything.me
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

unspecified
2.0 S4 (20june)
All
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 verified, b2g-v2.1 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
E/GeckoConsole( 9814): [JavaScript Error: "TypeError: icon is undefined" {file: "app://collection.gaiamobile.org/js/contextmenu.js" line: 34}]
(Assignee)

Updated

3 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Blocks: 1016203
(Assignee)

Comment 1

3 years ago
Created attachment 8442716 [details]
Github pull request

thanks
Attachment #8442716 - Flags: review?(ran)

Updated

3 years ago
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
Comment on attachment 8442716 [details]
Github pull request

Awesome
Attachment #8442716 - Flags: review?(ran) → review+
(Assignee)

Comment 3

3 years ago
Merged in master:

https://github.com/crdlc/gaia/commit/4f3019ca9325dac282e3d910d2a7ad9d84e0579c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
Comment on attachment 8442716 [details]
Github pull request

Needed for the vertical homescreen.
Attachment #8442716 - Flags: approval-gaia-v2.0?(bbajaj)

Updated

3 years ago
Keywords: verifyme

Updated

3 years ago
Attachment #8442716 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
2.0: https://github.com/mozilla-b2g/gaia/commit/060a9050dcd7475c3940ce16421ea28e6ed2241b
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed

Comment 6

3 years ago
Verified the issue is fixed on 2.2, 2.1 and 2.0
Content menu is not displayed when pressing empty spaces in collections 

Device: Flame 2.2 Master KK
BuildID: 20141027040237
Gaia: e91d99e4d96954f06383c00bb9d79598a697e310
Gecko: 8230834302c9
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1 KK
BuildID: 20141027001201
Gaia: c97463d61f45513a2123b19610386ddbfc916819
Gecko: 4f8c0c021128
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Device 2.0 KK
BuildID: 20141027000202
Gaia: 2183b4f3ec0eb47ab1f133c31732ec53b08ad253
Gecko: 43bee45176c4
Gonk: 6e51d9216901d39d192d9e6dd86a5e15b0641a89
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-] → [VH-FL-blocking-][VH-FC-blocking-][QAnalyst-Triage?]
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-][QAnalyst-Triage?] → [VH-FL-blocking-][VH-FC-blocking-][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.