Crash when selecting a message in more than one folder

VERIFIED FIXED in M9

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
19 years ago
a year ago

People

(Reporter: scottputterman, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In this morning's build if I view a message in a folder and then switch to
another folder and try viewing another message I get the below assertion.
Continuing gets the crash below.  I can view more than one message in the same
folder.

The assertion:

NTDLL! 77f76148()
nsDebug::PreCondition(const char * 0x01b478e8
??_C@_0DJ@KMGL@You?5can?8t?5dereference?5a?5NULL?5nsC@, const char * 0x01b4792c
??_C@_0N@NHHF@mRawPtr?5?$CB?$DN?50?$AA@, const char * 0x01b4a1d8
??_C@_0CB@MCGB@?4?4?2?4?4?2?4?4?2dist?2include?2nsCOMPtr?4h@, int 504) line 143
+ 13 bytes
nsCOMPtr<nsIContent>::operator->() line 504 + 34 bytes
nsCSSFrameConstructor::ContentRemoved(nsCSSFrameConstructor * const 0x025e4110,
nsIPresContext * 0x025be5c0, nsIContent * 0x03065350, nsIContent * 0x031f3cc0,
int 0) line 4672 + 32 bytes
nsCSSFrameConstructor::RecreateFramesForContent(nsIPresContext * 0x025be5c0,
nsIContent * 0x031f3cc0) line 6066 + 28 bytes
nsCSSFrameConstructor::AttributeChanged(nsCSSFrameConstructor * const
0x025e4110, nsIPresContext * 0x025be5c0, nsIContent * 0x031f3cc0, nsIAtom *
0x01dd7d10 {"selectedrow"}, int 2) line 5291 + 16 bytes
StyleSetImpl::AttributeChanged(StyleSetImpl * const 0x025e41b0, nsIPresContext *
0x025be5c0, nsIContent * 0x031f3cc0, nsIAtom * 0x01dd7d10 {"selectedrow"}, int
-1) line 845
PresShell::AttributeChanged(PresShell * const 0x025e5f88, nsIDocument *
0x025b9d80, nsIContent * 0x031f3cc0, nsIAtom * 0x01dd7d10 {"selectedrow"}, int
-1) line 1834 + 50 bytes
XULDocumentImpl::AttributeChanged(XULDocumentImpl * const 0x025b9d80, nsIContent
* 0x031f3cc0, nsIAtom * 0x01dd7d10 {"selectedrow"}, int -1) line 1949
RDFElementImpl::UnsetAttribute(RDFElementImpl * const 0x031f3cc0, int 0, nsIAtom
* 0x01dd7d10 {"selectedrow"}, int 1) line 2178
nsTreeCellFrame::Select(nsIPresContext & {...}, int 0, int 1) line 303
nsTreeFrame::ClearSelection(nsIPresContext & {...}) line 173
nsTreeFrame::SetSelection(nsIPresContext & {...}, nsTreeCellFrame * 0x036b8b20)
line 69
nsTreeCellFrame::HandleMouseDownEvent(nsIPresContext & {...}, nsGUIEvent *
0x0012fb8c, nsEventStatus & nsEventStatus_eConsumeDoDefault) line 204
nsTreeCellFrame::HandleEvent(nsTreeCellFrame * const 0x036b8b20, nsIPresContext
& {...}, nsGUIEvent * 0x0012fb8c, nsEventStatus &
nsEventStatus_eConsumeDoDefault) line 175
PresShell::HandleEvent(PresShell * const 0x025e5f84, nsIView * 0x025e4420,
nsGUIEvent * 0x0012fb8c, nsEventStatus & nsEventStatus_eConsumeDoDefault) line
2241 + 38 bytes
nsView::HandleEvent(nsView * const 0x025e4420, nsGUIEvent * 0x0012fb8c, unsigned
int 28, nsEventStatus & nsEventStatus_eConsumeDoDefault, int & 0) line 834
nsViewManager::DispatchEvent(nsViewManager * const 0x025e4640, nsGUIEvent *
0x0012fb8c, nsEventStatus & nsEventStatus_eConsumeDoDefault) line 1736
HandleEvent(nsGUIEvent * 0x0012fb8c) line 67


The crash:

nsCSSFrameConstructor::ContentRemoved(nsCSSFrameConstructor * const 0x025e4110,
nsIPresContext * 0x025be5c0, nsIContent * 0x03065350, nsIContent * 0x031f3cc0,
int 0) line 4672 + 38 bytes
nsCSSFrameConstructor::RecreateFramesForContent(nsIPresContext * 0x025be5c0,
nsIContent * 0x031f3cc0) line 6066 + 28 bytes
nsCSSFrameConstructor::AttributeChanged(nsCSSFrameConstructor * const
0x025e4110, nsIPresContext * 0x025be5c0, nsIContent * 0x031f3cc0, nsIAtom *
0x01dd7d10 {"selectedrow"}, int 2) line 5291 + 16 bytes
StyleSetImpl::AttributeChanged(StyleSetImpl * const 0x025e41b0, nsIPresContext *
0x025be5c0, nsIContent * 0x031f3cc0, nsIAtom * 0x01dd7d10 {"selectedrow"}, int
-1) line 845
PresShell::AttributeChanged(PresShell * const 0x025e5f88, nsIDocument *
0x025b9d80, nsIContent * 0x031f3cc0, nsIAtom * 0x01dd7d10 {"selectedrow"}, int
-1) line 1834 + 50 bytes
XULDocumentImpl::AttributeChanged(XULDocumentImpl * const 0x025b9d80, nsIContent
* 0x031f3cc0, nsIAtom * 0x01dd7d10 {"selectedrow"}, int -1) line 1949
RDFElementImpl::UnsetAttribute(RDFElementImpl * const 0x031f3cc0, int 0, nsIAtom
* 0x01dd7d10 {"selectedrow"}, int 1) line 2178
nsTreeCellFrame::Select(nsIPresContext & {...}, int 0, int 1) line 303
nsTreeFrame::ClearSelection(nsIPresContext & {...}) line 173
nsTreeFrame::SetSelection(nsIPresContext & {...}, nsTreeCellFrame * 0x036b8b20)
line 69
nsTreeCellFrame::HandleMouseDownEvent(nsIPresContext & {...}, nsGUIEvent *
0x0012fb8c, nsEventStatus & nsEventStatus_eConsumeDoDefault) line 204
nsTreeCellFrame::HandleEvent(nsTreeCellFrame * const 0x036b8b20, nsIPresContext
& {...}, nsGUIEvent * 0x0012fb8c, nsEventStatus &
nsEventStatus_eConsumeDoDefault) line 175
PresShell::HandleEvent(PresShell * const 0x025e5f84, nsIView * 0x025e4420,
nsGUIEvent * 0x0012fb8c, nsEventStatus & nsEventStatus_eConsumeDoDefault) line
2241 + 38 bytes
nsView::HandleEvent(nsView * const 0x025e4420, nsGUIEvent * 0x0012fb8c, unsigned
int 28, nsEventStatus & nsEventStatus_eConsumeDoDefault, int & 0) line 834
nsViewManager::DispatchEvent(nsViewManager * const 0x025e4640, nsGUIEvent *
0x0012fb8c, nsEventStatus & nsEventStatus_eConsumeDoDefault) line 1736
HandleEvent(nsGUIEvent * 0x0012fb8c) line 67
nsWindow::DispatchEvent(nsWindow * const 0x025e42e4, nsGUIEvent * 0x0012fb8c,
nsEventStatus & nsEventStatus_eIgnore) line 489 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fb8c) line 514
nsWindow::DispatchMouseEvent(unsigned int 302, nsPoint * 0x00000000 {x=???
y=???}) line 3256 + 15 bytes
ChildWindow::DispatchMouseEvent(unsigned int 302, nsPoint * 0x00000000 {x=???
y=???}) line 3409
nsWindow::ProcessMessage(unsigned int 513, unsigned int 1, long 8716395, long *
0x0012fdc0) line 2519 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00140c74, unsigned int 513, unsigned int 1, long
8716395) line 578 + 27 bytes
(Reporter)

Updated

19 years ago
Summary: Can't select a message in more than one folder → Crash when selecting a message in more than one folder
(Reporter)

Comment 1

19 years ago
Changing summary

Comment 2

19 years ago
Pls fix for M9.
(Reporter)

Comment 3

19 years ago
*** Bug 10288 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Blocks: 10288

Comment 4

19 years ago
I think this is working now?  I recall selecting a message in a different folder
in today's (7/27) release builds on Windows NT 4.0.
(Reporter)

Comment 5

19 years ago
I think this got fixed because I'm not seeing it anymore.

Comment 6

19 years ago
hyatt - perhaps you want to close this bug out?
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
I pronounce this bug fixed. :)

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Linux and Mac (1999-08-16-08 M9) and WIn_nt 4.0 (1999-08-16-09 M9)
I can view a message in a folder and then switch to
another folder and try viewing another message, no more problem.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.