Play sound doesn't seem to play if your phone is muted

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: pdehaan, Assigned: vkrishnamoorthy)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:2.0+)

Details

(Reporter)

Description

4 years ago
related to #1027749

---

via https://github.com/mozilla-services/FindMyDevice/issues/116

Found in http://fmd.dev.mozaws.net/status/ (commit ad58eac)

{
  "goroutines": 22,
  "status": "ok",
  "version": "0.7-ad58eac2ebf27542491972f7706efae624557582"
}

Using B2G 2.0.0.0-prerelease, 320a2 (build id: 20140618160200 (aurora)), git sha 23e06c36

### Steps to reproduce:
1. Log in to http://fmd.dev.mozaws.net/
2. Press "Play Sound" (and cover your ears).
3. Drop the volume until zero/muted.

### Actual results:
(silence)

### Expected results:
vibrate or otherwise notify me if the sound should be playing.

Comment 1

4 years ago
If this is the case, this is a regression. Play Sound worked on both muted, and 'Silence Calls' modes in the past implementation. MozTrap tests exist for this case.

Updated

4 years ago
blocking-b2g: --- → 2.0?
Keywords: regression

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Keywords: regressionwindow-wanted

Comment 2

4 years ago
My device does not appear on the provided website once Find My Device is enabled. ("Sorry but you don't have any devices.") 

I noticed that the real page is not implemented yet (bug 992929). Would my device connect to the .dev database by default, and if not is there a way to connect to it?

Device: Buri 2.0
BuildID: 20140624000201
Gaia: 9d2f7bd16a8dc0c74c97c5a40d2f0731f3dfff4b
Gecko: f118b45daada
Version: 32.0a2 (2.0) 
Firmware Version: v1.2device.cfg
Flags: needinfo?(pdehaan)
Lionel, here are instructions: https://wiki.mozilla.org/User_Services/Try_FMD it's a little complex so join us in #wmf on IRC for real-time help.
After discussing this with Peter on IRC, it looks like the behavior he's seeing is exactly the one I intended: Play Sound will always max out the volume, then start playing, but make no attempt to prevent you from turning down the volume while it plays.

As Kate pointed out, the sound _is_ supposed to start playing at full volume if the phone is muted by the time the Play Sound request arrives, so if that's not happening, then it's definitely a bug. Otherwise, I don't think being able to turn down the volume _while_ the sound plays is a bug.

I personally think the behavior we have is reasonable, and if that's the case, then this is not really a bug at all. Vishy, do you agree?
Flags: needinfo?(vkrishnamoorthy)
I'm not sure about the regression status of this, either. Assigning to Vishy since we need him for the next steps.
Assignee: nobody → vkrishnamoorthy
Keywords: productwanted
(Assignee)

Comment 6

4 years ago
this is not a regression. 
When the user has muted the device and plays sound, the devices does ring.
Once the device is ringing, the user can reduce the volume (all the way to mute) using the hardware buttons.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(vkrishnamoorthy)
Resolution: --- → FIXED
Thanks Vishy, changing to "invalid" since a code change didn't land to resolve this but rather, a decision. 
:)
Resolution: FIXED → INVALID

Updated

4 years ago
Flags: needinfo?(pdehaan)
Keywords: productwanted, regression, regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.