[@ xpc::WindowOrNull(JSObject*) ]

RESOLVED DUPLICATE of bug 994657

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 994657
4 years ago
4 years ago

People

(Reporter: Jonatan Svensson Glad, Unassigned)

Tracking

33 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140619030203

Steps to reproduce:

function iwindows_crash()

{

	var i, new_win, new_doc;

	for(i = 1; ;++i)
	{
		new_win = window.open("blank.htm", "wind" + i);
		new_doc = new_win.document;
		new_doc.open();
		new_doc.writeln("<html>");
		new_doc.writeln("<head>");
		new_doc.writeln("<title>Windows #" + i + "</title>");
		new_doc.writeln("<h3>Windows #" + i + "</h3>");
		new_doc.writeln("<hr>");
		new_doc.writeln("</head>");
		new_doc.writeln("<body>");
		new_doc.writeln("</body>");
		new_doc.writeln("</html>");
		new_doc.close();
	}

}


Actual results:

It crashed.
This bug could be avoid in a browser simply by having a reasonable upper limit on the number of browser windows that can be open at any one time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 994657
You need to log in before you can comment on or make changes to this bug.