If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Replace the deprecated initEvent code with the CustomEvent constructor in browser/components/preferences/in-content/preferences.js

RESOLVED FIXED in Firefox 33

Status

()

Firefox
Preferences
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jaws, Assigned: vikneshwar, Mentored)

Tracking

Trunk
Firefox 33
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment)

From bug 754304 comment #24:

> +  var initFinished = document.createEvent("Event");
> +  initFinished.initEvent("Initialized", true, true);

Nit: FYI initEvent is deprecated.
Summary: Remove the deprecated initEvent code in browser/components/preferences/in-content/preferences.js → Replace the deprecated initEvent code with the CustomEvent constructor in browser/components/preferences/in-content/preferences.js
Assignee: nobody → lviknesh
Status: NEW → ASSIGNED
(Assignee)

Comment 1

3 years ago
Created attachment 8443640 [details] [diff] [review]
custom-event.patch

Mochitest on browser/components/preferences passed , but on browser/base/content/test/general gave this http://pastebin.com/Eew9shxR
Attachment #8443640 - Flags: feedback?(jaws)
Comment on attachment 8443640 [details] [diff] [review]
custom-event.patch

Review of attachment 8443640 [details] [diff] [review]:
-----------------------------------------------------------------

I couldn't reproduce the test failures on my machine. This looks good to me.

Pushed to try server, https://tbpl.mozilla.org/?tree=Try&rev=b0f5a70d27ec
Attachment #8443640 - Flags: feedback?(jaws) → review+
After the tryserver results come back, then we can set the checkin-needed keyword on the bug.
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/4471d1aa007c
Keywords: checkin-needed
Whiteboard: [good first bug] → [good first bug][fixed-in-fx-team]

Comment 5

3 years ago
https://hg.mozilla.org/mozilla-central/rev/4471d1aa007c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [good first bug][fixed-in-fx-team] → [good first bug]
Target Milestone: --- → Firefox 33
You need to log in before you can comment on or make changes to this bug.