[Homescreen] Bookmarking an app doesn't show on homescreen

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Homescreen
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Anshul, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR:
1. Swipe vertically on the homescreen to see the search bar
2. Enter any keyword, "travel" for example
3. Click on any of the results, "trip advisor" for example
4. Click the ^ icon at the bottom of the app and select favorite icon (star shaped icon).
5. Click on the name of the app and then "Add to Home Screen" button in the next window that pops up.

Expected: The app icon to be available on the home screen
Observed: No app icon is available.
(Reporter)

Comment 1

3 years ago
The app shows up fine after I restart the phone or restart the b2g process.
(Reporter)

Comment 2

3 years ago
The issue is reproduced on version 2.0
Gecko: f6c59193a0102d1b2ffb136b5d1d42fd30f93446
Gaia: 5b1fdc6000d35962769e789b924b24e166a27759
The commit here is a week old. We should retest this on the latest 2.0.
Keywords: qawanted
blocking-b2g: 2.0? → 2.0+

Comment 4

3 years ago
Created attachment 8443645 [details]
2014-06-20-13-41-39.png

I was unable to reproduce this bug on either the latest Flame 2.0 or Flame master.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140620015245
Gaia: 27f07f479e696af304d52e5fdd654317baa8c17d
Gecko: 15efc384af1f
Version: 32.0a2 (2.0)
Firmware Version: v121-2

Environmental Variables:
Device: Flame 2.1 - Master
Build ID: 20140619180845
Gaia: ccd70903544486bea04e85d8a4aacf63f1de2a72
Gecko: bdac18bd6c74
Version: 33.0a1 (2.1 - Master)
Firmware Version: v121-2

When bookmarking the TripAdvisor app from the search menu, the bookmark appears at the very bottom of the homescreen app list.
Flags: needinfo?(anshulj)

Updated

3 years ago
Flags: needinfo?(jmitchell)
We are unable to repro this issue on the latest - if no-one else can we should close this as works-for-me
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: qawanted
(Reporter)

Comment 6

3 years ago
Working fine on the latest 2.0. 

Gecko: 44a1f09d553b3cc6e7db4771a00596e21939e8dd
Gaia: f34a662d7747101e32b32e9855b21026ab10e4f2
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(anshulj)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.