Composer: insert link causes crash

VERIFIED WONTFIX

Status

P4
major
VERIFIED WONTFIX
20 years ago
20 years ago

People

(Reporter: driehuis, Assigned: akkzilla)

Tracking

1998-09-04
Other
BSDI

Details

(Reporter)

Description

20 years ago
When inserting a link into a page in Composer, Mozilla dies.

To repeat:
 - start Mozilla
 - File->New->Blank Page
 - Click the link icon
 - Text: "foo", link to: "bar"
 -foom!

Program received signal SIGSEGV, Segmentation fault.
0xc9b4cc1 in _XimLocalFilter ()
(gdb) bt
#0  0xc9b4cc1 in _XimLocalFilter ()
#1  0xc98e53d in XFilterEvent ()
#2  0xc8f496e in _XtDefaultDispatcher ()
#3  0xc8f4bd3 in XtDispatchEvent ()
#4  0xc889d14 in RemoveAllPMgr ()
#5  0xc8ea3e3 in XtCallCallbackList ()
#6  0xc8f0cb3 in Phase2Callbacks ()
#7  0xc8f0bd1 in Recursive ()
#8  0xc8f0f72 in XtPhase2Destroy ()
#9  0xc8f115e in _XtDoPhase2Destroy ()
#10 0xc8f4bf4 in XtDispatchEvent ()
#11 0xc8fdc63 in XtAppProcessEvent ()
#12 0x808cfdc in fe_EventLoop ()
#13 0x808ef29 in main ()
#14 0x805ebc4 in __start ()

BSD/OS 4.0, X11R6, Motif 1.2.2, autoconf build, CVS as of 1998/10/07
Clean build with -O2
../configure  --with-nspr=/usr/local/nspr --enable-editor --enable-mail-compose
--enable-ldap

Updated

20 years ago
Assignee: ramiro → akkana

Comment 1

20 years ago
This is a composer bug.  Akkana owns the XFE composer.  thanks.

Reassign to akkana@netscape.com.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

20 years ago
I can't reproduce this on my IRIX (non-autoconf) build.  I'll try an autoconf
build with those flags on some other platforms and see if I can reproduce it.

We've seen similar stack traces in the past on Solaris, where a destroy callback
wasn't being called from phase2destroy, or where the object owning a widget had
been deleted too early in the process before the widget's destroy callback was
called.  Knowing which widget was being deleted would be a big help; if you see
this stack trace again (or if you still have the core file handy), could you try
to find out the widget's XtName in any of the stages 5 through 9 in the stack
trace?  That's in case I'm not able to reproduce it here, though I'll try.

What flavor of BSD are you on?

Comment 3

20 years ago
Setting all current Open Critical and Major to M3

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WONTFIX

Comment 4

20 years ago
this is an old codebase bug, marking resolved won't fix in MozillaClassic

Updated

20 years ago
Status: RESOLVED → VERIFIED
QA Contact: 3849

Comment 5

20 years ago
marking as verified since this is against old code, if applicable in apprunner,
please open a new bug
You need to log in before you can comment on or make changes to this bug.