If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Alt text displays even after image has been rendered

VERIFIED DUPLICATE of bug 11011

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 11011
19 years ago
13 years ago

People

(Reporter: marina, Assigned: pmock)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Steps to reproduce:
-open 4.6;
-go to any URL(http://www.cnndanmark.dk/);
-save this Web page as an HTML file;
-send mail with this file attached;
-get it in 5.0;
//now note: HTML tags appearing on the top of the page
(it doesn't occur when the page is sent in-line, and you see it correctly when
you just bring up the saved web page in the Browser window);
-it happens when the file is sent as an attachement in 7/20/99 windows build

Updated

19 years ago
QA Contact: lchiang → pmock

Updated

19 years ago
Assignee: phil → rhp

Comment 1

19 years ago
reassigning to rhp.  If this isn't an attachment problem, maybe this should be
reassigned to the layout team?

Updated

19 years ago
Assignee: rhp → rickg

Comment 2

19 years ago
Hi Rick,
I'm not sure to assign this to, but it looks like a parsing/layout problem. I
will attach an HTML file that is the output from libmime's parsing operation.
If you load this into 4.x or IE, it seems fine, but with Gecko, you get parts
of HTML showing up in the display.

- rhp

Comment 3

19 years ago
Created attachment 962 [details]
The HTML that has tags being displayed with Gecko

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 4

19 years ago
Rich -- The attachment appears identical to me in nav and in Gecko. Perhaps we
have a related problem -- or it's possible that whatever was wrong is fixed.
Would you mind resubmitting an attachment of a small html page (very small) in
English so I can scan it more easily in my debugger?

Comment 5

19 years ago
I don't see HTML tags showing up under 5.0, but there seem to be
some problems with ALT text showing up where it should not.

1. When you attach a locally saved page of the above URL, none of the links to
   image files (both .gif and .jpg) can be recovered since you don't get
   the reference links in the mail such as:

   Content-Base: "http://www.cnndanmark.dk/"
   Content-Location: "http://www.cnndanmark.dk/"

   which you would get if you send a page directly from a location. Since
   almost all images are defined relative to the above base location,
   you can locate images without the reference link.

2. Under 4.x, you don't see any ALT text displayed unless there is specific
   text defined in "ALT=name_of_image".
3. Under 5.0, you actually see ALT text material even if ALT is not
   defined at all. For example, you will see this name

   "forside_header_sidstenyt"

   near the top of the page. This is a name of a gif file without the
   extention, .gif, taken from this line:

  <IMG SRC=3D"/pics/global/forside_header_sidstenyt.gif" WIDTH=3D"86" =
HEIGHT=3D"19" BORDER=3D"0">

   There are a bunch of other image names showing up on this page
   under 5.0 when they cannot be located. For example, "552284" for
   "552284.jpg", etc. None of these are defined as ALT texts and
   so we have to assume that this is a bug.

By the way, I also see some problems with a live page message.
For example, I see the numbers 552284 and 552294. They are supposed
to be pictures. I can't tell from the source where 552294 comes from
but 552284 comes from this link.

http://www.cnndanmark.dk/images/recent/220699/552284.jpg

Under 4.6, this image is actually loaded in the atatchment of a
live page. In any case, 5.0 should not be displaying alternate
text unless it is defined in the document.

I observe only these kinds of problems on the locally-attached pages
and to a limited extent in live page attachments.
I don't see other problems with the problem message in question.

Comment 6

19 years ago
I should mention that my observations are based on Windows build: 1999072108.

Updated

19 years ago
Assignee: rickg → momoi
Status: ASSIGNED → NEW

Comment 7

19 years ago
The alttext issue is a known bug assigned to kipp. Rather than overload this bug
for that purpose, I'd be greatful if you would close this bug if you can't
reproduce it either. Then lets open a new one which we can mark as a dup (but
useful for testing) and assign to Kipp.

Comment 8

19 years ago
I talked briefly to marina today about her original problem.
She seemed to agree that what she had reported is the alt text
probelm I described above. Will confirm on Monday with marina
and follow your suggestions on opening a new one.

Updated

19 years ago
Assignee: momoi → marina

Comment 9

19 years ago
I'm going to send this over to marina.
Please confirm or disconfirm what has been discussed
above.

Comment 10

19 years ago
marina?
(Reporter)

Comment 11

19 years ago
What i was seeing were HTML source code strings or if we language it
differently- alt.text. In case there is a bug already entered for this it should
be dup.

Comment 12

19 years ago
Peter, pls look into this and reassign/open a new bug as needed.  Thanks.

Updated

18 years ago
Assignee: marina → pmock
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Summary: HTML tags appear in the mail attachement → Alt text displays even after image has been rendered
(Assignee)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Comment 13

18 years ago
Confirmed this problem is the Alt Text problem.

I was able to reproduce the problem on the Win32 1999-08-17-09-m9 build and
Linux 1999-08-17-08-m9 build.

Alt text is appearing next to the image.  I spoke with Marina to confirm her bug
description. She confirmed that she was seeing alt text.

Updating bug title:
 Old title - HTML tags appear in the mail attachement
 New title - Alt text displays even after image has been rendered

Marking this bug as duplicate of bug 11011 assigned to kipp.

/Peter
 Mail QA

*** This bug has been marked as a duplicate of 11011 ***
(Assignee)

Comment 14

18 years ago
Verified as duplicate of bug 11011
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.