Closed Bug 1028002 Opened 5 years ago Closed 5 years ago

First key press in dialer app doesn't work

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: anshulj, Assigned: etienne)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

46 bytes, text/x-github-pull-request
timdream
: review+
Details | Review
STR
1. Make sure the dialer app is not running in background. If it is, then kill the app
2. Open dialer app
3. Click on any number

Expected: The number that is pressed should be displayed in dialer
Observed: Dialer seems to be ignoring the first key press and in some cases even the second key press.

The issue is reproduced on version 2.0
Gecko: f6c59193a0102d1b2ffb136b5d1d42fd30f93446
Gaia: 5b1fdc6000d35962769e789b924b24e166a27759
The commit here is a week old. We should retest this on the latest 2.0.
Keywords: qawanted
I've seen that on 2.1 too. And a recent one. Clear blocker.

The first click can work if you wait a bit between opening the app and making the first click. That looks like a race.

Jason: Not sure how to ask for regression windows nowadays but we need one.
QA Contact: jharvey
blocking-b2g: 2.0? → 2.0+
This issue DOES reproduce on the latest Flame master, Flame 2.0, Buri 2.0

Environmental Variables:
Device: Flame 2.0
Build ID: 20140620101046
Gaia: 27f07f479e696af304d52e5fdd654317baa8c17d
Gecko: 606653d5d01d
Version: 32.0a2 (2.0)
Firmware Version: v121-2

Environmental Variables:
Device: Flame 2.1 - Master
Build ID: 20140620094247
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 892d7a8eda45
Version: 33.0a1 (2.1 - Master)
Firmware Version: v121-2

Environmental Variables:
Device: Buri 2.1 - Master
Build ID: 20140620094247
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 892d7a8eda45
Version: 33.0a1 (2.1 - Master)
Firmware Version: v1.2device.cfg

Environmental Variables:
Device: Buri 2.0
Build ID: 20140620101046
Gaia: 27f07f479e696af304d52e5fdd654317baa8c17d
Gecko: 606653d5d01d
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg

Tapping on any of the keys with in the Dialer app have no effect after immediately entering the app.

This issue does NOT reproduce on the latest Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140610034016
Gaia: c39db439202b29897bee9896bc789e6782809f3a
Gecko: edd648be2b07
Version: 30.0 (1.4)
Firmware Version: v121-2

Tapping any of keys in the Dialer app, even after immediately entering the app has the expected effect.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Assignee: nobody → etienne
Target Milestone: --- → 2.0 S5 (4july)
Good thing I took it, it's a window manager issue :)
Component: Gaia::Dialer → Gaia::System::Window Mgmt
Attached file Gaia PR
Hey Tim, since Alive is on PTO I'm flagging you for review but I can also bug Vivien if needed :)
Attachment #8444498 - Flags: review?(timdream)
Central Regression Window

Last Working
Environmental Variables:
Device: Flame 2.0
Build ID: 20140529133000
Gaia: b669dd2cc321f37cebc7081a79b968cac36b4200
Gecko: b85b57f05fda
Version: 32.0a1 (2.0)
Firmware Version: v121-2

First Broken
Environmental Variables:
Device: Flame 2.0
Build ID: 20140529193003
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: 38c5e21a80fa
Version: 32.0a1 (2.0)
Firmware Version: v121-2

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: b669dd2cc321f37cebc7081a79b968cac36b4200
Gecko: 38c5e21a80fa

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: b85b57f05fda

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/b669dd2cc321f37cebc7081a79b968cac36b4200...26d8fcab9b61f46451600f39c51e0387ef3c4f88
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Target Milestone: 2.0 S5 (4july) → ---
Broken by bug 950673.
Blocks: 950673
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Comment on attachment 8444498 [details] [review]
Gaia PR

Spend some time investigated what this patch means. Looks good but I don't really understand why we were working on the same thing (waiting for app to be |loaded|) at two bugs (bug 1021270 and bug 950673)!
Attachment #8444498 - Flags: review?(timdream) → review+
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #8)
> Comment on attachment 8444498 [details] [review]
> Gaia PR
> 
> Spend some time investigated what this patch means. Looks good but I don't
> really understand why we were working on the same thing (waiting for app to
> be |loaded|) at two bugs (bug 1021270 and bug 950673)!

Yeah it was a bit of mess. I'm pretty sure the fix here was part of a review comment at some point.
https://github.com/mozilla-b2g/gaia/commit/5f2c61ae3bbdad0c46c2ef5c808182a099e429c9
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1024595
Depends on: 1031572
I believe this is already covered in Moztrap test case: https://moztrap.mozilla.org/manage/case/8504/
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(srapanan)
This test case seemed to fit better. Added an expected step:

https://moztrap.mozilla.org/manage/case/8470/
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(srapanan)
Flags: in-moztrap+
Issue does NOT repro on 2.0 and 2.1 Flame 319MB

I am hearing sound on all of the keypad inputs.

Environmental Variables:
Device: Flame 2.0 319MB
BuildID: 20140916000205
Gaia: 7edd3b0b9f65c3dde235c732d270e43e055a1254
Gecko: f3639e825b3b
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Enviromental Variables:
----------------------------------------
Device: Flame 2.1 319MB
BuildID: 20140916000206
Gaia: 713448b8963cd53c561f4b38640f8c63b655ce33
Gecko: e2a4798c3f91
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.