Closed Bug 1028042 Opened 6 years ago Closed 6 years ago

Reinstate the activity handler for the OMA DD Mime type also

Categories

(Firefox OS Graveyard :: Runtime, defect)

defect
Not set

Tracking

(blocking-b2g:2.0+, firefox31 wontfix, firefox32 fixed, firefox33 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
firefox31 --- wontfix
firefox32 --- fixed
firefox33 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: amac, Assigned: amac)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(1 file)

Bug 1021156 reinstated the activity handler for the direct message OMA DRM type, but the descriptor type wasn't reinstated. That means that it's still being handled by the Download Manager which then doesn't know what to do with this. This bug is just to ensure that the descriptor MIME type files are also handled by the activity.
Summary: Downloads can't always go to download manager; FL app requires special handling of two mime types → Reinstate the activity handler for the OMA DD Mime type also
This patch just enables the handling of the other OMA type via an activity.
Attachment #8443336 - Flags: review?(21)
Requesting blocking on this because this is a feature that was working on 1.3 and stopped working when the activity handlers were disabled.
blocking-b2g: --- → 2.0?
blocking-b2g: 2.0? → 2.0+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Check this issue on today's (06/25) master buri build:
Gecko-330cda2
Gaia-756f1ae

Now downloading dd files is working fine.
You need to log in before you can comment on or make changes to this bug.