No working IMAP options to update server folders without messages synchronization

REOPENED
Unassigned

Status

MailNews Core
Networking: IMAP
REOPENED
4 years ago
3 years ago

People

(Reporter: Artem S. Tashkinov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8443386 [details]
prefs.js (personally identifiable information stripped)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20140609182057

Steps to reproduce:

OK, I have these options enabled:

user_pref("mail.server.default.offline_download", false);
user_pref("mail.server.server1.downloadByDate", false);
user_pref("mail.server.server1.downloadUnreadOnly", false);
user_pref("mail.server.server1.offline_download", false);
user_pref("mail.server.server2.downloadByDate", false);
user_pref("mail.server.server2.downloadUnreadOnly", false);
user_pref("mail.server.server3.downloadByDate", false);
user_pref("mail.server.server3.downloadUnreadOnly", false);
user_pref("mail.server.server3.offline_download", false);

and

user_pref("mail.check_all_imap_folders_for_new", true);
user_pref("mail.server.default.check_all_folders_for_new", true);
user_pref("mail.server.server1.check_all_folders_for_new", true);
user_pref("mail.server.server1.check_new_mail", true);
user_pref("mail.server.server1.check_time", 5);
user_pref("mail.server.server3.check_all_folders_for_new", true);
user_pref("mail.server.server3.check_new_mail", true);
user_pref("mail.server.server3.check_time", 30);

And still for both of my IMAP accounts only the Inbox folder gets updated. All others need to be checked manually (mouse click them) to see new messages in them.

What am I doing wrong?

Updated

4 years ago
Blocks: 1008543
(Reporter)

Comment 1

4 years ago
Right click the folder you're interested in, check, "When getting new messages for this account, always check this folder".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Comment 2

4 years ago
yes  :)
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

4 years ago
(In reply to Wayne Mery (:wsmwk) from comment #2)

Yes or no, imagine I have multiple (more than twenty) folders in my IMAP account - such a "solution" becomes a chore.

Comment 4

4 years ago
note, this setting is not a performance option. Although you probably do not have enough folders to see a problem. ref: bug 729504.

(In reply to Artem S. Tashkinov from comment #3)
> (In reply to Wayne Mery (:wsmwk) from comment #2)
> 
> Yes or no, imagine I have multiple (more than twenty) folders in my IMAP
> account - such a "solution" becomes a chore.

hmm, check_all_imap_folders_for_new = true should have worked for you.

Did it work in version 24?
Status: VERIFIED → REOPENED
Ever confirmed: true
Flags: needinfo?(t.artem)
Resolution: INVALID → ---
(Reporter)

Comment 5

4 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)

I've never run Thunderbird 24, so I've no idea.

If you're interested, I can check how old Thunderbird handles this option.

Version 31 definitely doesn't care about it.

Comment 6

4 years ago
rsx11m, can you assist?
Flags: needinfo?(t.artem) → needinfo?(rsx11m.pub)

Updated

4 years ago
Component: Untriaged → Networking: IMAP
Product: Thunderbird → MailNews Core

Comment 7

3 years ago
Sorry but I don't really have the use case of multiple IMAP folders of an account being able to receive new messages, thus can't comment or help in a useful way... maybe WADA has a clue.
Flags: needinfo?(rsx11m.pub) → needinfo?(m-wada)
(In reply to rsx11m from comment #7)
> I don't really have the use case of multiple IMAP folders of an account being able to receive new messages, (snip)

Use case which I know:
(A)  "When getting new messages for this account, always check this folder" of some IMAP folders :
         Server side message filter is used, and mails are moved to other than Inbox.
(B)  check_all_imap_folders_for_new = true :
         I don't know why this is mandatory for a Thunderbird user.
         A possible use case is;
            IMAP account is shared by multiple peoples, and multiple IMAP clients on multiple PC moves mails among IMAP folders.
            A Tb user needs to know such moved mails to other than Inbox by other peoples.
           So, "Check new message every NN minutes" is needed for any IMAP folder.
        Why this option was implemented :
           Some Thunderbird users wanted it.

I can't understand reason why this bug is still kept open even after above known options have been introduced to bug opener, by someone or by bug opener himself.
Problem is next?
   Bug opener wants "check new messages every NN minutes" for more than twenty IMAP folders,
   but doesn't want "check new messages every NN minutes" for all IMAP folders.

If outstanding issue is "check_all_imap_folders_for_new=true doesn't work as bug opener expects", it may be following, but I'm not sure.

When an IMAP folder(call FolderX) is not selected at a cached connection, Tb uses "STATUS FolderX" is used for new mail check.
> http://tools.ietf.org/html/rfc3501#section-6.3.10
> 6.3.10. STATUS Command 
> 
>           Because the STATUS command is not guaranteed to be fast
>           in its results, clients SHOULD NOT expect to be able to
>           issue many consecutive STATUS commands and obtain
>           reasonable performance.
>  
>     The currently defined status data items that can be requested are:
>        MESSAGES
>        RECENT
>        UIDNEXT
>        UIDVALIDITY
>        UNSEEN

"one 'STATUS FolderX' on FolderX per one minute" may produce other issue than server side performance issue. It depends on IMAP server.
It may depend on number of "mails with \Recent flag"(==actual newly-arrived message at IMAP server) and number of "mail without \Seen flag"(Unread mail, which is new mail for Thunderbird if UID is not known for Tb).

I don't know which data item is requested by Thunderbird.
I don't know when Tb issues "select FolderX, uid fetch 1:* Flags()" or "select FolderX, uid fetch HighestUID:* Flags()" after "STATUS FolderX".
I don't know IMAP level flow when CONDSTORE is supported by server and Tb's CONDSTORE support is enabled(enabled by default).
Flags: needinfo?(m-wada)

Comment 9

3 years ago
mail.check_all_imap_folders_for_new doesn't seem to exist in tb 31 (at least it's not in config editor). 

mail.server.default.check_all_folders_for_new works for the stated use case, at least for me.
(In reply to Chris Haumesser from comment #9)

Sorry, we use term of mail.check_all_imap_folders_for_new for any actual entry name of ;
   mail.check_all_imap_folders_for_new
   mail.server.default.check_all_folders_for_new 
   mail.server.server#.check_all_folders_for_new 
I believe "who is responsible to use actual one in his environment" is not us. It's user himself.
> Google Search result.
> https://www.google.com/?gws_rd=ssl#q=mail.check_all_imap_folders_for_new
> http://kb.mozillazine.org/How_do_I_check_for_new_messages_in_other_folders#IMAP
> Set mail.check_all_imap_folders_for_new to true to make Thunderbird check every remote folder for new mail. 
> The downside is there is no way to exclude a specific folder (such as a junk mail folder). 
> (Versions after TB 5.0 replaced the global preference with server-specific ones, thus modify
>  mail.server.default.check_all_folders_for_new instead to make it effective for all accounts with modify this preference 
>  using the Config Editor.
You need to log in before you can comment on or make changes to this bug.