ASSERTION: need base URL: 'nsnull != aBaseURL', nsCSSParser.cpp#771

RESOLVED FIXED

Status

()

Core
CSS Parsing and Computation
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: bbaetz, Assigned: bz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in bug 95336, URL)

(Reporter)

Description

16 years ago
1. To reproduce: go to the tinderbox page
2. Click on a 'star'. As the popup comes up, you get the assertion.
This is due to us using the wrong document (the one from nsIContent, not the one
from nsINodeInfo).  As a result, we get no base URI on elements that are being
styled before being added to the DOM. My patch in bug 95336 fixes this.

Taking; I'll resolve this once bug 95336 is checked in.
Assignee: dbaron → bzbarsky
Depends on: 95336
OS: Linux → All
Hardware: PC → All
Whiteboard: fix in bug 95336
Fixed by checkin for bug 95336
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.