Closed Bug 1028271 Opened 7 years ago Closed 7 years ago

[B2G][Dialer]Call logs are not displaying correctly with the patch from bug 1021248

Categories

(Core :: Graphics: Layers, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla33
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified

People

(Reporter: astole, Assigned: kats)

References

()

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

Attached file logcat
When first opening the call log when there is call history, nothing is shown until selecting the edit button or selecting a different menu then returning to the call log.

Repro Steps:
1) Update a Flame to BuildID: 20140620040204
2) Make or receive a call to DUT
3) Open dialer app
4) Select call log

Actual:
There is no information displayed in the call log

Expected:
The call log displays correct information

2.1 Environmental Variables:
Device: Flame 2.1
BuildID: 20140620040204
Gaia: ccd70903544486bea04e85d8a4aacf63f1de2a72
Gecko: bdac18bd6c74
Version: 33.0a1
Firmware Version: v121-2

User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Repro frequency: 2/2, 100%
See attached: logcat, video
This issue does not repro on the latest 2.0 on Flame. The call log displays correct information.

2.0 Environmental Variables:
Device: Flame 2.0
BuildID: 20140620000202
Gaia: c5dd47e3f9e18872961946735fdbc071a1656ac9
Gecko: 71b1b4b0850c
Version: 32.0a2
Firmware Version: v121-2
Note:

When attempting to edit the call log, sometimes there are no check boxes and if there are check boxes, the numbers can be selected but no check appears in the box notifying that the number has been selected.
Note:

Also, after closing the edit menu, the date ('Today' in video) is cut off above number in call log.
Flags: needinfo?(jmitchell)
blocking-b2g: --- → 2.1?
Flags: needinfo?(jmitchell)
QA Contact: pcheng
Duplicate of this bug: 1026451
Mozilla inbound regression window:

Last Working Environmental Variables:
Device: Flame
Build ID: 20140619055933
Gaia: 82e957160ca017087bd374cd051339e55b641e68
Gecko: 5f1041f40876
Version: 33.0a1 (2.1 - Master) 
Firmware Version: v121-2

First Broken Environmental Variables:
Device: Flame
Build ID: 20140619062833
Gaia: 82e957160ca017087bd374cd051339e55b641e68
Gecko: f17c906538c9
Version: 33.0a1 (2.1 - Master) 
Firmware Version: v121-2

Gaia is the same on both builds, which means this is a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5f1041f40876&tochange=f17c906538c9
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Broken by either bug 1021248 or bug 1026756.

kats - can you figure out which patch caused this & either backout the patch or fix this quickly?
Component: Gaia::Dialer → Graphics: Layers
Flags: needinfo?(bugmail.mozilla)
Product: Firefox OS → Core
Version: unspecified → Trunk
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
The patches on bug 1021085 seem to fix this, based on my local testing. They're pending review and should land soonish but if you don't want to wait I can back out and reland everything together. Let me know.
Assignee: nobody → bugmail.mozilla
Depends on: 1021085
Flags: needinfo?(bugmail.mozilla)
I landed bug 1021085 on inbound just now which I think should fix this. After some more local testing I was only able to intermittently reproduce this issue though so I may be wrong. Would like somebody who can consistently reproduce this to retest with an inbound build that includes bug 1021085 to see if it is fixed.
Flags: needinfo?(jsmith)
Ok - marking qawanted to get someone to test this on the latest mozilla-inbound build.
Flags: needinfo?(jsmith)
Keywords: qaurgent, qawanted
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [lead-review+]
QA Whiteboard: [lead-review+]
This issue DOES reproduce on the latest Mozilla Inbound build.

Environmental Variables:
Device: Flame 2.1 
Build ID: 20140623055944
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 6aade5365ee1
Version: 33.0a1
Firmware Version: v121-2
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, qawanted
So we've confirmed above we can still reproduce with the patch mentioned.

kats - can we backout the regressing patch here & see what's causing this?
Flags: needinfo?(bugmail.mozilla)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Ok, but I'm going to need better STR if I have a chance of fixing this at all, because the last few times I tried I couldn't reproduce it at all. How many items are in the call log when this happens? Is it less than a screenful or more?
Andrew or Harvey- can you address the question in comment 12?
Flags: needinfo?(astole)
I backed out bug 1021248 to fix this (in my local testing that was the one of the two patches that seemed to be the culprit).

https://hg.mozilla.org/integration/mozilla-inbound/rev/0f07aa386616
Flags: needinfo?(bugmail.mozilla)
Ok - will mark this fixed via backout once the changeset from comment 14 merges to central.
I managed to grab a log from one instance of this problem occurring. The log indicates that AboutToCheckerboard is returning true when it shouldn't be, and so the paint gets aborted and it just blanks.

The metrics that result in AboutToCheckerboard returning true are:

content metrics: critdp=(0, 0, 320x500.333344) viewportScroll=(0, 0)
compositor metrics: viewportScroll=(-0, 0) cb=(0, 0, 480x751)

When the composition bounds is converted to CSS pixels (1.5 scale) it ends up 320x500.666667 which is 0.3333 taller than the critical displayport, and so the painted area doesn't "contain" the visible area. This is basically a rounding error. I can fix it as part of bug 1024126.
Blocks: 1021248
Depends on: 1024126
No longer depends on: 1021085
Flags: needinfo?(astole)
Summary: [B2G][Dialer]Call logs are not displaying correctly → [B2G][Dialer]Call logs are not displaying correctly with the patch from bug 1021248
Oh, also in comment 16, the scrollableRect is 320x500.333344 so clamping the "showing" area to the scrollable rect would also have fixed it in this instance.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #14)
> I backed out bug 1021248 to fix this (in my local testing that was the one
> of the two patches that seemed to be the culprit).
> 
> https://hg.mozilla.org/integration/mozilla-inbound/rev/0f07aa386616

Has merged to m-c now.
Clearing flags now that the regressing patch has been backed out.
blocking-b2g: 2.1? → ---
Resolving since the regressing patch was backed out. The underlying issue behind this bug (as described in comment 16) was also fixed by bug 1024126. I verified that locally on a build that had the patch from bug 1024126 without the backout.

Not sure if this should be resolved FIXED or WORKSFORME (or even duped to 1024126?) but since there's no actual patch on here I'll close this as WFM for now.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Usually I mark fixed by backout as FIXED mainly because the regressing patch being backed out counts as the patch to fix the bug.
blocking-b2g: --- → 2.1+
Resolution: WORKSFORME → FIXED
Target Milestone: --- → mozilla33
The edit window in call log displays and functions as expected. Unable to reproduce issue.

Device: Flame Master M/C
BuildID: 20140625040202
Gaia: 57da30f405ba37a5d4844f32bb292271b81faee2
Gecko: a19e0434ea52
Version: 33.0a1
Firmware Version: v122

resolving as verified fixed
Status: RESOLVED → VERIFIED
Verified fixed in latest Flame 2.1 build.
Call log displays properly each time it is opened.

Environmental Variables:
Device: Flame 2.1
BuildID: 20141021001201
Gaia: e458f5804c0851eb4e93c9eb143fe044988cecda
Gecko: ee86921a986f
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.