crash when I click on Search button in any html form

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
2 years ago

People

(Reporter: spider, Unassigned)

Tracking

({crash})

Other Branch
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (WinNT; U)
BuildID:    2001091303

for example go to "http://www.yahoo.com" type anything in search form
and click on Search button.

Reproducible: Always
Steps to Reproduce:
1.go to http://www.yahoo.com
2.type in search text field some text
3.click on Search button 

Actual Results:  Mozilla crashed
(Reporter)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.4

Comment 1

17 years ago
Tigran, if you are crashing in Mozilla the best thing you can do to help the
developers fix your bug is to attach a stacktrace. If you're not building
yourself you are not out of luck.  Mozilla (thanks to a very cool donation from
Netscape) releases nightly and milestone builds with Full Circle's Talkback.
Talkback should catch most crashes and offer to send in a crash report. I can
retrieve that crash report and attach it to your bug report if you provide
either the Incident ID (you can get it by running the talkback program from
/components/talkback/) or you can let me know the email address you used to
submit the report and the time of sending. Thanks for your help in testing
Mozilla and reporting bugs.

Also, Target Milestone is used by the developer to let people know when the bug
is likely to be fixed. 
Keywords: crash
Target Milestone: mozilla0.9.4 → ---

Comment 2

17 years ago
Tigran, thanks for the followup. In the future please comment to the bug rather
than email (there is a link at the top of this message). It is also helpful if
you can include the TalkBack Incident ID in a comment in crashing bugs (run
talkback.exe from the components/ directory in your install directory to get the
ID of reports you've sent in). I was able to look this one up by email but the
ID makes it easier. Thanks again for your help in testing Mozilla. 

Based on the stack trace from Talkback I'm moving this bug to the PSM component.

Incident ID 36244911
Stack Signature GetOCSPResponders f120381d
Bug ID
Trigger Time 2001-10-03 22:33:19
Email Address spider@zvartnots.am
User Comments just type any text in search field and press Search button.
Build ID 2001091311
Product ID Netscape6.20
Platform ID Win32
Trigger Reason Access violation
Stack Trace
GetOCSPResponders
[d:\builds\seamonkey\mozilla\security\manager\ssl\src\nsNSSCertificate.cpp, line
3278]
nsOCSPResponder::CompareEntries
[d:\builds\seamonkey\mozilla\security\manager\ssl\src\nsNSSCertificate.cpp, line
3262]
nsGenericFactory::CreateInstance
[d:\builds\seamonkey\mozilla\xpcom\components\nsGenericFactory.cpp, line 62]
nsComponentManagerImpl::CreateInstance
[d:\builds\seamonkey\mozilla\xpcom\components\nsComponentManager.cpp, line 1285]
nsComponentManager::CreateInstance
[d:\builds\seamonkey\mozilla\xpcom\components\nsRepository.cpp, line 82]
nsServiceManagerImpl::GetService
[d:\builds\seamonkey\mozilla\xpcom\components\nsServiceManager.cpp, line 345]
nsServiceManager::GetService
[d:\builds\seamonkey\mozilla\xpcom\components\nsServiceManager.cpp, line 560]
nsGetServiceByCID::operator()
[d:\builds\seamonkey\mozilla\xpcom\components\nsServiceManager.cpp, line 48]
nsCOMPtr_base::assign_from_helper
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 66]
nsFormFrame::OnSubmit
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsFormFrame.cpp, line 708]
nsHTMLFormElement::DoSubmitOrReset
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLFormElement.cpp,
line 518]
nsHTMLFormElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLFormElement.cpp,
line 462]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5660]
PresShell::HandleEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5630]
nsFormControlHelper::DoManualSubmitOrReset
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsFormControlHelper.cpp, line
1005]
nsHTMLButtonControlFrame::MouseClicked
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsHTMLButtonControlFrame.cpp,
line 367]
nsHTMLInputElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLInputElement.cpp,
line 1265]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5660]
PresShell::HandleEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5630]
nsEventStateManager::CheckForAndDispatchClick
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 2466]
nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 1552]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5681]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5585]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 377]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 350]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 350]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2058]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 68]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 732]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 749]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4264]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4514]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3251]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 997]
USER32.dll + 0x124c (0x77e7124c) 
Assignee: asa → ssaux
Status: UNCONFIRMED → NEW
Component: Browser-General → Client Library
Ever confirmed: true
Product: Browser → PSM
QA Contact: doronr → junruh
Version: other → unspecified

Comment 3

17 years ago
This is a dup of 101213. We checked in some code since then, and because your
stack trace is exactly as the one on 101213, you don't seem to run a version
which includes the patch (which inserts code before line 3278 in
nsNSSCertificate.cpp)

*** This bug has been marked as a duplicate of 101213 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED

Comment 5

14 years ago
REOPEN:
this bug has nothing to do w/ 101213. Read the summary.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

13 years ago
Assignee: ssaux → nobody
Status: REOPENED → NEW

Comment 6

13 years ago
I do not see the crash. If you still have this problem, please reopen the bug and assign it to me (or cc me).
Status: NEW → RESOLVED
Last Resolved: 17 years ago13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.