Closed Bug 10283 Opened 21 years ago Closed 21 years ago

[feature] [PP]Patch: Macintosh patching a text file fails with error -220

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect, P3, major)

PowerPC
Mac System 8.5

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: jimmykenlee, Assigned: cathleennscp)

References

Details

Build: 7/20/99 SeaMonkey build

1. From http://jimbob/trigger2.html, enter or use drop-down to trigger
   a_addmacpatch.jar to add text file for patching
2. Then trigger a_macpatch.jar

NOTE:
This test used to work.  I don't know exactly which build it began to fail.

RESULT:
The file is added correctly.  After triggering a_macpatch.jar, the "macpatch"
directory ends up with two files, smrtupdt-1.txt and smrtupdt.txt.

The Install.log shows:
---------------------------------------------------------------------------
http://jimbob/jars/a_addmacpatch.jar     --     07/21/1999 11:19:14
---------------------------------------------------------------------------

     Acceptance: a_addmacpatch

     Item [1/1]	Installing: Webbies:moz720:macpatch:smrtupdt.txt

     Install completed successfully
     Finished Installation  07/21/1999 11:19:15

---------------------------------------------------------------------------
http://jimbob/jars/a_macpatch.jar     --     07/21/1999 11:20:01
---------------------------------------------------------------------------

     Acceptance: a_macpatch

     ** ERROR (-220): Patching: Webbies:moz720:macpatch:smrtupdt.txt

     Install script aborted
     Finished Installation  07/21/1999 11:20:01

EXPECTED RESULT:
No error message in Install.log.  Only one file remains in "macpatch" directory
after patching is applied.
Assignee: dveditz → cathleen
Target Milestone: M10
I'll try to take a look at this bug.
Blocks: 11020
Summary: [PP]Patch: Macintosh patching a text file fails with error -220 → [feature] [PP]Patch: Macintosh patching a text file fails with error -220
Blocks: 11207
Status: NEW → ASSIGNED
Jimmy, can you check if smrtupdt.txt is indeed patched correctly?

If it is, then all we need to do is to clean up smrtupdt-1.txt (which is
the extracted patch data file), then this is a dup of bug 10297 and I have a fix
ready for it.
Build 8/16/99

There has been a change.  The patching is now failing.  Instead of
"smrtupdt.txt", the result of patching is "smrtupdt_patch.txt.gdf".  Yes, I
compared the patch, and it is all that remains when patching is completed.
There is no file by "smrtupdt-1.txt" that remains.

The Install.log shows the following:

---------------------------------------------------------------------------
http://jimbob/jars/a_addmacpatch.jar     --     08/17/1999 16:05:53
---------------------------------------------------------------------------
Acceptance: a_addmacpatch

Item [1/1]Installing: Webbies:moz816:mozilla-mac-M9:macpatch:smrtupdt.txt
Install completed successfully
Finished Installation  08/17/1999 16:05:56

---------------------------------------------------------------------------
http://jimbob/jars/a_macpatch.jar     --     08/17/1999 16:07:32
---------------------------------------------------------------------------
Acceptance: a_macpatch

Item [1/1]Patching: Webbies:moz816:mozilla-mac-M9:macpatch:smrtupdt.txt
Install **FAILED** with error 6
Install **FAILED** with error 6
Finished Installation  08/17/1999 16:07:34
Blocks: 12805
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Jimmy, I can't seem to reproduce this problem on Don's Mac, so I'm marking this
as WORKSFORME.

Since you're seeing the file gets deleted, it may be due to the bug where we
fail to update registry file at the finalize stage (due to currupted registry
file).

Please try to see if you can still reproduce the problem first, and then rename
your old registry and created a new file from 4.6, and try to see if the problem
should go away.

Dan also checked in fix where if we do get registry update err at the end of
patching process, we will ignore the err and continue, and thus won't cause the
file gets deleted afterwards.  see bug 12242
Status: RESOLVED → VERIFIED
Build 9/7/99

Patching a text file works.  My netscape registry may have been corrupted since
I did create a new one to verify.
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.