screen constantly turning off

RESOLVED DUPLICATE of bug 1028374

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 1028374
4 years ago
4 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
master + m-c, June 20, Flame

STR:

1. bluetooth is turned off
2. open an image in gallery, choose bluetooth file share
3. choose to enable bluetooth
4. wait for other bluetooth devices to be listed

Expected: screen stays on

Actual: screen turns off while waiting
Dietrich, how long do you wait for bt devices to be listed? Is it turned off screen while device is idle? I don't find out any abnormal behaviour via the description.
Flags: needinfo?(dietrich)
Per offline discussion with John Lu and Evan, all of us meet the screen is turned off in few seconds automatically while a user is operating the phone via screen(not home key, power key). We suspect the timer of triggering screen idle is broken some where.

Dietrich, do you meet the issue in other page too?
(Reporter)

Comment 3

4 years ago
Over the weekend I saw this all over. It's not Bluetooth only.

Requesting blocking 2.0 for QA to test. Otherwise it should block 2.1.
blocking-b2g: --- → 2.0?
Component: Gaia::Bluetooth File Transfer → Gaia
Flags: needinfo?(dietrich)
Keywords: qawanted, regression, regressionwindow-wanted
Summary: screen allowed to turn off during bluetooth pairing process while sharing → screen constantly turning off
(Reporter)

Comment 4

4 years ago
Tested on Flame 6/24 build, still happening, reproducible every time:

1. Turned display timeout to 5 minutes
2. View homescreen and don't touch the phone again
3. After 10 seconds, screen turns off
4. After 3 seconds, screen turns back on showing lock screen
5. After 10 seconds, screen turns off again

Updated

4 years ago
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Last Resolved: 4 years ago
Keywords: qawanted, regression, regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1028374
You need to log in before you can comment on or make changes to this bug.