Closed Bug 1028337 Opened 6 years ago Closed 6 years ago

ClassCastException when closing all private tabs

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 33
Tracking Status
firefox33 --- affected
fennec 33+ ---

People

(Reporter: mcomella, Assigned: mcomella)

References

Details

(Keywords: crash, regression, reproducible)

Crash Data

Attachments

(1 file)

1) Open tabs panel
2) Click private tabs panel
3) Hit hamburger button
4) Click "Close Private Tabs"

Expected: Close private tabs is probably disabled as there are no private tabs
Acutal: Crash!

Stack trace:

06-20 11:09:41.426 E/GeckoAppShell(14537): java.lang.ClassCastException: org.mozilla.gecko.tabspanel.PrivateTabsPanel cannot be cast to org.mozilla.gecko.tabspanel.TabsPanel$CloseAllPanelView
06-20 11:09:41.426 E/GeckoAppShell(14537):      at org.mozilla.gecko.tabspanel.TabsPanel.onMenuItemClick(TabsPanel.java:231)
06-20 11:09:41.426 E/GeckoAppShell(14537):      at org.mozilla.gecko.widget.GeckoPopupMenu.onMenuItemClick(GeckoPopupMenu.java:153)
06-20 11:09:41.426 E/GeckoAppShell(14537):      at org.mozilla.gecko.menu.GeckoMenu.handleMenuItemClick(GeckoMenu.java:575)
06-20 11:09:41.426 E/GeckoAppShell(14537):      at org.mozilla.gecko.menu.GeckoMenu.onItemClick(GeckoMenu.java:551)
06-20 11:09:41.426 E/GeckoAppShell(14537):      at android.widget.AdapterView.performItemClick(AdapterView.java:298)
06-20 11:09:41.426 E/GeckoAppShell(14537):      at android.widget.AbsListView.performItemClick(AbsListView.java:1100)
06-20 11:09:41.426 E/GeckoAppShell(14537):      at android.widget.AbsListView$PerformClick.run(AbsListView.java:2749)
06-20 11:09:41.426 E/GeckoAppShell(14537):      at android.widget.AbsListView$1.run(AbsListView.java:3423)

The same behavior occurs when a private tab is created:

06-20 11:18:59.488 E/GeckoAppShell(15087): java.lang.ClassCastException: org.mozilla.gecko.tabspanel.PrivateTabsPanel cannot be cast to org.mozilla.gecko.tabspanel.TabsPanel$CloseAllPanelView
06-20 11:18:59.488 E/GeckoAppShell(15087):      at org.mozilla.gecko.tabspanel.TabsPanel.onMenuItemClick(TabsPanel.java:231)
06-20 11:18:59.488 E/GeckoAppShell(15087):      at org.mozilla.gecko.widget.GeckoPopupMenu.onMenuItemClick(GeckoPopupMenu.java:153)
06-20 11:18:59.488 E/GeckoAppShell(15087):      at org.mozilla.gecko.menu.GeckoMenu.handleMenuItemClick(GeckoMenu.java:575)
06-20 11:18:59.488 E/GeckoAppShell(15087):      at org.mozilla.gecko.menu.GeckoMenu.onItemClick(GeckoMenu.java:551)
06-20 11:18:59.488 E/GeckoAppShell(15087):      at android.widget.AdapterView.performItemClick(AdapterView.java:298)
06-20 11:18:59.488 E/GeckoAppShell(15087):      at android.widget.AbsListView.performItemClick(AbsListView.java:1100)
06-20 11:18:59.488 E/GeckoAppShell(15087):      at android.widget.AbsListView$PerformClick.run(AbsListView.java:2749)
06-20 11:18:59.488 E/GeckoAppShell(15087):      at android.widget.AbsListView$1.run(AbsListView.java:3423)
I made CloseAllPanelView extend PanelView and cleaned that up while I was at it.
Attachment #8443691 - Flags: review?(margaret.leibovic)
Assignee: nobody → michael.l.comella
Status: NEW → ASSIGNED
Blocks: 817716
tracking-fennec: --- → ?
Keywords: regression
Comment on attachment 8443691 [details] [diff] [review]
Fix crash when closing all private tabs.

Review of attachment 8443691 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, thanks for the patch. Looks like PrivateTabsPanel was added just before I landed my patch, so I didn't know about it!
Attachment #8443691 - Flags: review?(margaret.leibovic) → review+
Duplicate of this bug: 1028926
Severity: normal → critical
Crash Signature: [@ java.lang.ClassCastException: org.mozilla.gecko.tabspanel.PrivateTabsPanel cannot be cast to org.mozilla.gecko.tabspanel.TabsPanel$CloseAllPanelView at org.mozilla.gecko.tabspanel.TabsPanel.onMenuItemClick(TabsPanel.java)]
Keywords: crash, reproducible
QA Contact: aaron.train
Hardware: All → ARM
Version: unspecified → Trunk
https://hg.mozilla.org/mozilla-central/rev/78ffdbef077c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
"Close Private Tabs" now closes the private tabs opened, so verified fixed on:
Device: Samsung Galaxy Nexus (Android 4.2.1)
Build: Firefox for Android 33.0a1 (2014-06-25)
Status: RESOLVED → VERIFIED
tracking-fennec: ? → 33+
You need to log in before you can comment on or make changes to this bug.