Closed Bug 1028372 Opened 7 years ago Closed 7 years ago

nsMsgMaildirStore::FinishNewMessage in imap->local maildir filter has message in cur not tmp

Categories

(MailNews Core :: Backend, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 856519

People

(Reporter: rkent, Unassigned)

Details

The fix in bug 827048 that gets maildir filters working leaves an unresolved issue, fixed with a kludge, that FinishNewMessage is expecting the new message to be in the tmp folder, when it has already moved to the cur folder.

We need to clearly specify the expectations of each of these many methods so that we have a consistent way of dealing with this.
At least one reason for this is the duplicated FinishNewMessage here http://hg.mozilla.org/comm-central/annotate/c72f18c8c604/mailnews/local/src/nsLocalMailFolder.cpp#l2265

This is being addressed in bug 856519, so let's dup it there.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 856519
You need to log in before you can comment on or make changes to this bug.