Betfred.com does not prompt to save passwords

RESOLVED INVALID

Status

()

Toolkit
Password Manager
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: bug.zilla, Unassigned)

Tracking

33 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140619030203

Steps to reproduce:

Visited Betfred.com and entered password


Actual results:

No prompt to save password appeared. signon.storeWhenAutocompleteOff is set to the default true.


Expected results:

Prompt to save password.
Could this be because a pop-up appears to enter the log-in details?

Updated

4 years ago
QA Whiteboard: [bugday-20140630]
Component: Untriaged → Password Manager
OS: Windows 7 → All
Product: Firefox → Toolkit

Comment 1

4 years ago
Reproduced with 2014-06-24-03-02-00-mozilla-central-firefox-33.0a1.ru.linux-x86_64.
The page isn't using a form submission to submit the username and password (they are using a click event on an <a>) so we don't know that the user is submitting the form. The site should be using a form submission with event.preventDefault(); and a button if they wanted normal form behaviour (e.g. submitting the form with Enter or saving passwords). Marking as invalid since things are working as designed.

If they were at least using a <button> or <input type=submit> then it may be reasonable to notice the click inside a <form> with an <input type=password> and show a dismissed doorhanger notification if this was a common pattern on websites. Doing this for clicks on <a> seems a bit weird though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.