Closed Bug 10284 Opened 21 years ago Closed 21 years ago

[PP]Adding binary file loses resource fork

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect, P3, major)

PowerPC
Mac System 8.5

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jimmykenlee, Assigned: samir_bugzilla)

Details

Build: 7/20/99 SeaMonkey build

1. Using http://jimbob/trigger2.html, enter or used drop-down and trigger
   f_addmacpatch_exe.  This will add 'Note Pad' to a directory.

var regName = "f_macpatch_exe";
var vi = new InstallVersion();
var jarSrc = "mac_folder"; //Note Pad is contained in this folder
var f;
var appenddir = "mac_patch_here"

vi.init("8.8.8.8");
Install.StartInstall("Functional: f_addmacpatch_exe", "/f_macpatch_exe", vi, 0);
f = Install.GetFolder("Program", "f_macpatch_exe");
Install.AddDirectory(regName, vi, jarSrc, f, appenddir, true);

RESULT:
The Install.log indicates that the installation is successful.  The directory is
installed as expected.  'Note Pad' is installed, and the Kind is document.
Opening this installed 'Note Pad' with ResEdit indicates that there is no
resource fork.

EXPECTED RESULT:
'Note Pad' is installed, and the Kind is Application.  'Note Pad' should have a
resource fork after installing.  Using a tool like Fetch to pull down 'Note Pad'
does properly reconstruct file as an Application Kind.
Assignee: dveditz → dougt
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → INVALID
I am highly suspicion that this is an invalid test case.  Notepad is a windows
application and by definition will not have a macintosh resource fork.  Also, I
can not reproduce this patching test case because I have no idea what the
original file is that will be patched.

I am closing as an INVALID.
Status: RESOLVED → REOPENED
I should have been more clear.  I can see the misunderstanding.  Actually, I am
using the Macintosh 'Note Pad' application.  I found mine under System
Folder:Apple Menu Items in System 8.5.  If you cannot find it, I'll send you a
copy of mine.  Sorry about that.
Don't be misled by the name of the jar file.  This is not a patching problem.  I
named it this way because it is a set up jar file for patching a binary.

This bug is about adding a binary file on Macintosh.  See me if this is unclear.
Status: REOPENED → NEW
Target Milestone: M10
after talking with jimmy, I understand the problem.  First, installing mac files
with resources is busted.  I am changing this bug's subject to reflect this.
Secondly, once this bug is fixed, there may be problems with patching.

Assigning to me.
Resolution: INVALID → ---
Clearing Invalid resolution due to reopen.
Assignee: dougt → sgehani
Will check in nsAppleSingleDecoder when the tree re-opens. Reassigning to
myself.
Status: NEW → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
Checked in. Marking fixed.

See:
http://puma/xpinstall/test/trigger.html [Testcase: AppleSingle Decode] or
http://puma/xpinstall/test/ASDecode.jar
that installs an AppleSingled SimpleText file.

Verify this by checking the About menu in SimpleText deployed in the
"Program" folder (menu title altered to read something like "Samir modified
this...").
Status: RESOLVED → VERIFIED
Build 8/9/99

Looks good!
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.