Alert telephony.ConferenceGroup is undefined using Gaia in Desktop

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sphinx_knight, Assigned: sphinx_knight)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140608211810

Steps to reproduce:

I used Gaia with Firefox Desktop and started the simulator


Actual results:

an error "telephony.ConferenceGroup is undefined" spawned in the console


Expected results:

No error should have happened
(Assignee)

Comment 1

4 years ago
Created attachment 8443911 [details] [diff] [review]
patch.diff
Attachment #8443911 - Flags: review?(21)
(Assignee)

Comment 2

4 years ago
Created attachment 8443913 [details] [diff] [review]
patch_upstream.diff
Attachment #8443911 - Attachment is obsolete: true
Attachment #8443911 - Flags: review?(21)
Attachment #8443913 - Flags: review?(21)
(Assignee)

Comment 3

4 years ago
Created attachment 8443922 [details] [diff] [review]
patch_upstream.diff

Corrected quotes (linting)
Attachment #8443913 - Attachment is obsolete: true
Attachment #8443913 - Flags: review?(21)
Attachment #8443922 - Flags: review?(21)
Comment on attachment 8443922 [details] [diff] [review]
patch_upstream.diff

Review of attachment 8443922 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with the following changes.

Since you can't push, I took the liberty to fix the small nits I made and test your change against our Continuous Integration server (See https://tbpl.mozilla.org/?tree=Gaia-Try&rev=4602da1bfcf77686e015161984b62dabdea2ad3e).

If the CI is green, I will land the patch. Thanks for the contribution.

::: apps/callscreen/js/conference_group_handler.js
@@ +5,5 @@
>  'use strict';
>  
>  var ConferenceGroupHandler = (function() {
>    var groupLine = document.getElementById('group-call');
> +  var groupLabel = document.getEleemntById('group-call-label');

nit: Please remove this broken change.

@@ +22,5 @@
>      CallsHandler.mergeConferenceGroupWithActiveCall();
>    };
>  
>    var telephony = window.navigator.mozTelephony;
> +  if(telephony.hasOwnProperty('conferenceGroup')) {

Please replace "if(" by "if (" to follow the guideline.
Attachment #8443922 - Flags: review?(21) → review+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Gaia-Try complains but for completely irrelevant tests here. Let's land that.
You need to log in before you can comment on or make changes to this bug.