download manager sort finished

RESOLVED DUPLICATE of bug 870659

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 870659
3 years ago
3 years ago

People

(Reporter: Clément Lefèvre, Unassigned)

Tracking

30 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

Nothing, it's just a common change since the new redesigned download manager.


Actual results:

Previously, when you had running downloads followed by finished one, unfinished ones were pushed on top of the download list. This is not the case anymore so if you've more than 3 finished downloads and you click on the "little" download manager, you can't see unfinished ones anymore. Hence, push them on top even temporarily just the time needed for them to finish would be helpful to have the informations instead of having something like "24 of 26 downloads finished, XXX MB over YYY MB" where XXX is the sum of current downloaded datas for the 26 files and YYY the total size : this is not very meaningful.

This could be done for the "big" download manager too (the one with ctrl/cmd + J), but is less important there.
(Reporter)

Updated

3 years ago
OS: Mac OS X → All
Hardware: x86 → All

Comment 1

3 years ago
There was a bug on that already.
QA Whiteboard: [bugday-20140630][DUPEME]
(Reporter)

Comment 2

3 years ago
Does someone know the bug number of the dupe? As there was now refresh here and no informations on which open bug to look at.

Updated

3 years ago
Component: Untriaged → Downloads Panel

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [bugday-20140630][DUPEME] → [bugday-20140630]
Resolution: --- → DUPLICATE
Duplicate of bug: 870659
You need to log in before you can comment on or make changes to this bug.