Flatten away public/src subdirectories under editor/

RESOLVED FIXED in mozilla33

Status

()

Core
Editor
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: poiru, Assigned: poiru)

Tracking

Trunk
mozilla33
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Assignee)

Description

4 years ago
This is similar to e.g. bug 946065.
(Assignee)

Comment 1

4 years ago
This would involve:
- Flattening away public/src subdirectories under editor/, editor/composer/, editor/txmgr/, and editor/txtsvc/
- Flattening away base subdirectory under editor/libeditor/

I could also flatten away the idl/ subdirectories if needed.

Would you be OK with this?
Flags: needinfo?(ehsan)

Comment 2

4 years ago
Yes please!
Flags: needinfo?(ehsan)

Comment 3

4 years ago
(FWIW flattening the idl dirs also sounds good, but it's cool if you don't want to do that work in this bug.)
(Assignee)

Comment 4

4 years ago
Created attachment 8444798 [details] [diff] [review]
Part 1: Flatten editor/composer/{public,src}/ directories
Assignee: nobody → birunthan
Status: NEW → ASSIGNED
Attachment #8444798 - Flags: review?(ehsan)
(Assignee)

Comment 5

4 years ago
Created attachment 8444799 [details] [diff] [review]
Part 2: Flatten editor/txmgr/{idl,public,src}/ directories
Attachment #8444799 - Flags: review?(ehsan)
(Assignee)

Comment 6

4 years ago
Created attachment 8444800 [details] [diff] [review]
Part 3: Flatten editor/txtsvc/{public,src}/ directories
Attachment #8444800 - Flags: review?(ehsan)
(Assignee)

Comment 7

4 years ago
Created attachment 8444801 [details] [diff] [review]
Part 4: Flatten editor/libeditor/base/ directory
Attachment #8444801 - Flags: review?(ehsan)
(Assignee)

Comment 8

4 years ago
Created attachment 8444802 [details] [diff] [review]
Part 5: Flatten editor/{idl,public}/ directories
Attachment #8444802 - Flags: review?(ehsan)

Updated

4 years ago
Attachment #8444798 - Flags: review?(ehsan) → review+

Updated

4 years ago
Attachment #8444799 - Flags: review?(ehsan) → review+

Updated

4 years ago
Attachment #8444800 - Flags: review?(ehsan) → review+

Updated

4 years ago
Attachment #8444801 - Flags: review?(ehsan) → review+

Updated

4 years ago
Attachment #8444802 - Flags: review?(ehsan) → review+
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/71f6b8a9b2e8 along with the changes from bug 1028559 for Android mochitest bustage: 
https://tbpl.mozilla.org/php/getParsedLog.php?id=42398428&tree=Mozilla-Inbound
Flags: needinfo?(birunthan)
(Assignee)

Updated

4 years ago
Keywords: leave-open
(Assignee)

Comment 14

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/faecfa9d0bb6

Try push: https://tbpl.mozilla.org/?tree=Try&rev=84fc6f1ad59a

Removing leave-open even though part 4 was never checked in (due to test failures caused by test reordering).
Keywords: leave-open
https://hg.mozilla.org/mozilla-central/rev/faecfa9d0bb6
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
You need to log in before you can comment on or make changes to this bug.