wrong handling Ctrl+Arrows after Ctrl-End in textarea

VERIFIED WORKSFORME

Status

()

Core
Keyboard: Navigation
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Adam Hauner, Assigned: mjudge)

Tracking

({embed, topembed-})

Trunk
mozilla1.0
x86
Windows NT
embed, topembed-
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE- DUPEME)

(Reporter)

Description

17 years ago
Description:
If you wrote several words in textarea, you can use Ctrl+[<--] and Ctrl+[-->]
for jumping on the beginning of previous/next word. After you press Ctrl+End,
both keyboard combinations are working bad.

Reproducibility:
Every time.

Steps to Reproduce:
1. write five words
2. place cursor on the text beggining 
3. press Ctrl+End (and cursor will move on the end of text)
4. try to press Ctrl+[<--] 
5. try to press Ctrl+[-->] 

Actual Results:
For 4: nothing happens, cursor is still on the end 
For 5: cursor skips on the beggining of second text

Expected Results:
For 4: skip on the beggining of fifth word
For 5: nothing

Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4+) Gecko/20011002

BTW I wanna add this bug using Bugzilla helper, but after filling it and submit,
 Alert window without text appear.

Updated

17 years ago
Assignee: aaronl → mjudge
Component: Keyboard Navigation → Selection
QA Contact: sairuh → tpreston
Whiteboard: DUPEME

Comment 1

17 years ago
-->Selection
No dupes found. Confirming with 2001100803 on Win2k. 

Adam: You may wish to try a fresh profile to see if that alleviates your
Bugzilla Helper problem. But, kudos to you that you emulated the form, instead
of giving up.

-> Keyboard Navigation, as this doesn't actually deal with Selection

Keyword: regression?
Assignee: mjudge → aaronl
Status: UNCONFIRMED → NEW
Component: Selection → Keyboard Navigation
Ever confirmed: true
QA Contact: tpreston → sairuh

Comment 3

17 years ago
No, this was in the right place before
Assignee: aaronl → mjudge

Comment 4

17 years ago
dup of another text area nav bug.
Status: NEW → ASSIGNED
Whiteboard: DUPEME → EDITORBASE DUPEME
Target Milestone: --- → mozilla1.0

Comment 5

17 years ago
the instructions are hard for me to follow, press control key and what other key(s)?
syd: To clarify steps 4 and 5, the "->" marks refer to the arrow keys. So, it'd
be Ctrl+ArrowLeft and Ctrl+ArrowRight, respectively.

Updated

17 years ago
Keywords: topembed

Updated

17 years ago
Keywords: topembed → embed, topembed-
EDT Triage (chofmann et al) editor bugs are not blocking spacely, minusing, 
keeping embed because we'll need it in a future product

EDITORBASE-

WFM: Using 2002032603 build on WinNT it works fine for me.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Whiteboard: EDITORBASE DUPEME → EDITORBASE- DUPEME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.