Global search: "Show/Open as list" results view does not remember/persist columns after Thunderbird restart

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #528044 +++

If I enable a column, say "status" it should still be there after Thunderbird restart. 

Reproducible: Always

Steps to Reproduce:
1. Search for some terms in "all messages"
2. In the faceted search tab, "View as list"
3. Enable a column.
4. Restart Thunderbird
5. repeat 1-2 above

Actual Results:  
Added column is gone

Expected Results:  
Column should still be shown.

Perhaps bug 710056 will be helpful. But Facet Search's message list view is not backed by a real folder.

Comment 1

4 years ago
This works fine for me. Are you restarting in a peculiar way?

Comment 2

4 years ago
I should note that I'm on a build from June 1, so it's possible that it broke in the meantime.
(Reporter)

Comment 3

4 years ago
I failed to follow the advice I was going to give the Tim and Ruben in Bug 570787 - I didn't test safe mode. 

My tests in sequence.
1. In my first test thunderbird did not shut down and I had to kill it. Column did not persist
2. In my second test (and multiple attempts) thunderbird shut down OK and column did not persist.
(I filed this bug)
3. I started thunderbird in SAFE mode, added column, restart normal (not safe) and column persisted!
4. start TB in normal mode, add another column, restart normal, all columns persisted.

Perhaps Tim and Ruben see similar results?

Comment 4

4 years ago
It's just setting and getting prefs. You should check to see what's under mailnews.database.global.views

Comment 5

4 years ago
Strange, now it works at mine too (tested in TB 31). I cannot reproduce, why it didn't work earlyer today.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 6

4 years ago
Yes works for me in 31
You need to log in before you can comment on or make changes to this bug.