Mediarecorder truncates final 2-3 seconds of recorded video

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: sdrinf, Unassigned)

Tracking

30 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8444064 [details]
ff_webcam_test.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

Steps to reproduce:
* Save http://pastebin.com/raw.php?i=iA04jpd3   to a new HTML file. This short test case creates a new mediarecorder object, records 5 seconds of video from the camera, then attempts to play it back, and load up the duration of the recorded video

* Open it in a new browser


Actual results:

Duration of the recorded video fluctuates between 1-4 seconds, instead of the 5 seconds requested length


Expected results:

5 seconds of video are recorded

Updated

5 years ago
Component: Untriaged → WebRTC: Audio/Video
Product: Firefox → Core
Component: WebRTC: Audio/Video → Video/Audio: Recording
There may be an implicit assumption here that record_start() starts actually recording instantly; I don't know the media recorder code well enough to say if this is a valid test.
(Reporter)

Comment 2

5 years ago
Manual testing showed record_start, and specifically, mediaRecorder.start() to behave responsively (the rest of the code just sets up recording & capturing). Further test nailed this down to cutting approx 1-1.5 sec from the end of videos.
Created attachment 8444273 [details]
The duration of recording blobs

I use your script to have a test on FireFox nightly linux build (2014-6-22) and the duration on control bar seems correct.
What is the test platform/version when you found this problem?
(Reporter)

Comment 4

5 years ago
FF 30.0 (latest & currently deployed stable), Windows 7 (x64). Laptop is an Asus Eee PC 1005HA (Seashell), webcam is an USB 2.0 UVC VGA built-in one.
Could you provide the CPU usage when the recording task is running?
(Reporter)

Comment 6

5 years ago
Steady at 70-90%: http://imgur.com/za8VpA1
It looks lika a duplication of Bug 994557 that fixed in FF31.
Hi SDr, 
Would you like to try nightly?
thanks.
(Reporter)

Comment 9

5 years ago
Repro with Firefox Nightly ( 33.0a1 (2014-06-24) ) failed to reproduce this error; evidencing a fix to be in the pipeline for this already. Nominating this bug dupe & closable.

If Benjamin's suspicion is correct re:dupe, and going by the timeline at https://wiki.mozilla.org/RapidRelease/Calendar  ,does this mean I can't count on fix until at least the 22nd of July? (Original itch was having a new product extension in pipeline with immediate release dates, blocked by this issue :/   )
According our release schedule, you may need to wait the next release version of firefox, or use the beta version instead.
https://bugzilla.mozilla.org/show_bug.cgi?id=1028669#c3
https://bugzilla.mozilla.org/show_bug.cgi?id=1028669#add_comment
According to those replys, set to WorkForMe after 33.0a1 nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.