www.drdobbs.com does not open under Firefox 30

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
4 years ago
4 years ago

People

(Reporter: raze.condition@gmail.com, Unassigned)

Tracking

30 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

I tried to open www.drdobbs.com using Firefox 30 in two different operating systems: Windows 7/64 and Ubuntu Linux 12.04 Precise / 32. Not a firewall issue, apparently (two different machines).
I tried this in several ways:
* Typing the URL in the address box.
* Providing the URL in the command line in Windows (Start | Run | "firefox.exe www.drdobbs.com")
* Googling, then clicking the link. 



Actual results:

The browser shows the 'Problem Loading Page' page, with the message 'The connection to the server was reset while the page was loading.'



Expected results:

www.drdobbs.com on the screen (happens in Chrome and IE11).
(Reporter)

Comment 1

4 years ago
The same happens for http://www.codeproject.com/.
Hi, 

thanks for taking time to report a problem.

I wasn't able to reproduce it on latest Nightly 33.0a1 20140623 with Debian (Linux x86_64). Nor with Firefox 30, on the same platform: both the provided URLs opened just fine.

Could you please try if the same happens to you in Safe Mode (Help → Restart with Addons disabled)?
And with a new profile? (see here how to create one → http://kb.mozillazine.org/Profile_Manager)

Cheers,
Francesca
Flags: needinfo?(raze.condition)
(Reporter)

Comment 3

4 years ago
Using a new profile, and safe mode, did not help.

I tried in my home computer, and the problem was not replicated: this seems to point to an environment issue at work. 

At work, the product 'eSafe Content Filtering' (http://www.safenet-inc.com/products/data-protection/content-security/esafe-content-filtering/) is installed. I think this may be a factor, if not the reason. 

Anyway, other browsers (Opera, Chrome, IE11) open these sites without problem. 

Thanks, 
Pablo.
Flags: needinfo?(raze.condition)
@Liz, any idea what to do here? 
I'm a bit conflicted: it's true that the problem probably originates from the content filtering software mentioned in Comment 3 and that would make this bug Invalid, but on the other hand in the same conditions (ie with the same content filtering software and/or filtering rules by the admins) other browsers work.

@Pablo: thanks for the additional info! Let's see what Liz suggest: I'm not sure that's something depending on Firefox, it can be that there are special filtering rules for your user + those URLs + Firefox that just don't apply if you use other browsers. 
In that case, the bug should be marked as Invalid, as wouldn't be - strictly speaking - a bug in Firefox. It's difficult to say without knowing how the content filtering works.

Cheers,
Francesca
QA Whiteboard: [bugday-20140707]
Flags: needinfo?(lhenry)
raze.connection, sorry I missed this bug from a couple of weeks ago. 
Can you try the steps listed here? 
Are other SSL sites also blocked? 
https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can
Flags: needinfo?(lhenry) → needinfo?(raze.condition)
no response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(raze.condition)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.