Closed Bug 1028775 Opened 5 years ago Closed 5 years ago

--disable-ion --disable-unified-compilation build fails: js/src/jsfriendapi.cpp:251: error: undefined reference to 'JSScript::principals()'

Categories

(Core :: JavaScript Engine, defect)

32 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox30 --- unaffected
firefox31 --- unaffected
firefox32 --- fixed
firefox33 --- fixed

People

(Reporter: jbeich, Assigned: jbeich)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1025674 +++

mozilla-aurora build fails with on platforms lacking Ion. The error is hidden behind implicit --enable-unified-compilation on mozilla-central as well as bug 1025674 and bug 1028745.

../../build/unix/gold/ld: error: objdir/js/src/jsfriendapi.o: requires dynamic R_X86_64_PC32 reloc against '_ZN8JSScript10principalsEv' which may overflow at runtime; recompile with -fPIC
../../build/unix/gold/ld: error: read-only segment has dynamic relocations
../../build/unix/gold/ld: error: hidden symbol '_ZN8JSScript10principalsEv' is not defined locally
c++: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[3]: *** [libmozjs-32a2.so] Error 1
Attached patch fixSplinter Review
--enable-ion bootlegging chain

In file included from js/src/jsfriendapi.cpp:26:
In file included from js/src/jsobjinlines.h:22:
In file included from js/src/jsinferinlines.h:25:
In file included from js/src/jit/ExecutionMode-inl.h:14:
js/src/jsscriptinlines.h:10:2: error: test
#error test
 ^
1 error generated.

--enable-unified-compilation bootlegging chain

In file included from objdir/js/src/Unified_cpp_js_src2.cpp:67:
In file included from js/src/jsapi.cpp:87:
js/src/jsscriptinlines.h:10:2: error: test
#error test
 ^
1 error generated.
Attachment #8444228 - Flags: review?(nchen)
Attachment #8444228 - Flags: review?(nchen) → review?(luke)
Attachment #8444228 - Flags: review?(luke) → review+
Comment on attachment 8444228 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 1013326
User impact if declined: aurora broken / --disable-ion
Testing completed (on m-c, etc.): yes
Risk to taking this patch (and alternatives if risky): NPOTB
Attachment #8444228 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/aa2f06e6141a
Assignee: nobody → jbeich
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Comment on attachment 8444228 [details] [diff] [review]
fix

Aurora approval granted.
Attachment #8444228 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.