Misleading comments in bug entry form

VERIFIED DUPLICATE of bug 107085

Status

()

Bugzilla
Creating/Changing Bugs
VERIFIED DUPLICATE of bug 107085
17 years ago
5 years ago

People

(Reporter: John Levon, Assigned: myk)

Tracking

Details

(Whiteboard: enter_bug)

(Reporter)

Description

17 years ago
I reported this before to someone on IRC. The helper message that says :

"Some fields initialized from your user-agent, Mozilla/5.0 (X11; U; Linux i686;
 en-US; rv:0.9.4+) Gecko/20010928. If you think it got it wrong, please tell
endico@mozilla.org what it should have been."

is DEEPLY misleading. You get this on the way to committing a helped bug. The
clear implication is that the build version is included in the bug report (which
it is not). For one real-life example of this confusion :

http://bugzilla.mozilla.org/show_bug.cgi?id=101013

Please, save your newbie reporters and bug team some effort and remove/alter
this text.
(Reporter)

Comment 1

17 years ago
Note also bug 67813, which is related but of a wider scope. This particular
bug is (surely ?) easy to fix.
This is an issue with Bugzilla itself, not Bugzilla Helper.  The bug entry page
on Bugzilla has this text on it.

I think the proper course of action is if the site has that function turned on
(it's optional - the admin can turn it on or off) that the text also be recorded
in the initial comment instead of only being displayed to the user.  It is
correct to show that info to the user, because information was pulled from it
(the OS and platform values).  The routine taking that information has no clue
that there's even a build ID in there, since it's not looking for it (not all
browsers provide that information, so it has no reason to).

Another alternative would be perhaps to state specifically in that message what
information was extracted from it.  I think that might be a better route to go,
since there are a lot of cases where you don't want the UA String to be put in
the bug report.  Perhaps have a checkbox next to the UA string to say "include
my User Agent String in the bug report".
Assignee: endico → myk
Component: Bugzilla: Other moz.org Issues → Creating/Changing Bugs
Product: mozilla.org → Bugzilla
QA Contact: myk → matty
Summary: Misleading comments in bugzilla helper → Misleading comments in bug entry form
Target Milestone: --- → Bugzilla 2.16
Version: other → 2.15

Comment 3

17 years ago
I personally like the idea of pre-filling the UA string in the Additional
Comments in enter_bug.cgi... if you don't wish to include it, you (the user
entering the bug) can always delete it before clicking submit.  However, the
vast majority of the time it will be useful information (even beyond the scope
of the Mozilla project... if you have the setting on to detect OS/Platform then
it's quite likely you'd be interested in the entire referer).

Updated

17 years ago
Whiteboard: enter_bug
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
bug 107085 has a patch...

*** This bug has been marked as a duplicate of 107085 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
clearing milestones on DUPLICATE/WONTFIX/WORKSFORME/INVALID bugs (so they'll
show up as needing triage if they get reopened)
Target Milestone: Bugzilla 2.18 → ---

Comment 7

16 years ago
Verified dupe
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.