Closed Bug 1028790 Opened 7 years ago Closed 7 years ago

Messaging in-app settings are not following multi-tasking patterns

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set
normal

Tracking

(tracking-b2g:backlog)

RESOLVED DUPLICATE of bug 1007600
tracking-b2g backlog

People

(Reporter: rmacdonald, Unassigned)

References

Details

(Whiteboard: [priority])

Whereas settings that are specific to an app are typically a part of the app, Messaging settings are part of the settings app. This is causing some strange multi-tasking behaviours.

From Messaging, tap on the overflow menu ("...") and tap on the Settings link.

Actual behaviour
- App launch screen shows as the view loads
- Messaging and Settings show up as separate apps in the task switcher
- Swiping the left edge returns to messaging

Preferred 2.0 behaviour
Use an inline activity to retain the Messaging settings as part of the same sheet and the same window in the task switcher.

In future releases, consider moving messaging-specific settings to the settings app.
NI'ing Carrie - Hi Carrie - Feel free to NI me if you have questions or have any concerns. Thanks!
Flags: needinfo?(cawang)
Arthur, will we have inline activity for settings app for 2.0?
Flags: needinfo?(arthur.chen)
No, unless we have bug 1005827 resolved. Even so, it is still risky to land the feature in this time.
Flags: needinfo?(arthur.chen)
I've discussed this issue with Arthur and I think since the UI of Messages settings does look like Settings APP, the behavior of swiping to switch between two APPs is acceptable for now, but I agree that we shall remove it from Messages APP in the future release. Thanks!
Flags: needinfo?(cawang)
I note that now we have two different ways of displaying settings pages of an app:

1. The settings page of an app is defined in settings app. (ex: messaging app)
2. The settings page of an app is defined in the app itself. (ex: contacts, calendar, keyboard app...)

As we may support embedding the settings pages of 3rd-party apps (bug 1020063) in 2.1, the way we display the settings page of messaging app seems inconsistent to other apps. I was wondering is there any guideline for this?
Flags: needinfo?(rmacdonald)
This is a new feature, no blocking.
blocking-b2g: 2.0? → ---
Whiteboard: [priority]
(In reply to Arthur Chen [:arthurcc] from comment #5)
> I note that now we have two different ways of displaying settings pages of
> an app:
> 
> 1. The settings page of an app is defined in settings app. (ex: messaging
> app)
> 2. The settings page of an app is defined in the app itself. (ex: contacts,
> calendar, keyboard app...)
> 
> As we may support embedding the settings pages of 3rd-party apps (bug
> 1020063) in 2.1, the way we display the settings page of messaging app seems
> inconsistent to other apps. I was wondering is there any guideline for this?

Thanks, Arthur...

This bug was brought to my attention last night and Mike is working with Jenny to put together a proposal. So no guidelines yet but I'll NI Jenny to share them once they're available.

- Rob
Flags: needinfo?(rmacdonald) → needinfo?(jelee)
Hello Rob, the way message setting is behaving right now is not ideal but acceptable as Carrie pointed out.
After discussion with Arthur, for 2.1, I believe we will have a better solution for this: when launching message setting from Setting, it will actually take user to Message setting page (the message setting page exists in Message, not Setting). So when launching message setting from Message, it will not go to Settings anymore thus eliminating the problem. Tks!
Flags: needinfo?(jelee)
blocking-b2g: --- → backlog
After bug 1007600 landed this bug no longer exists.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1007600
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.