FFOS [flame] fail to distinguish operator types in network settings.

RESOLVED DUPLICATE of bug 997071

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 997071
4 years ago
4 years ago

People

(Reporter: 孟宪茂, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8444242 [details]
network type screenshot

Steps to reproduce:

a) Power on the flame device with a sim card.
b) Go to settings->Cellular and Data->Sim 1->Network Operator->Network Type->3G preferred.
c) Turn OFF automatic selection and search the network.
d) Flame fail to distinguish between 2G and 3G operators in the searching results and show the same results.

See the screenshot in the attachment.
(Reporter)

Comment 1

4 years ago
Hi peipei,

This issue exist in both FFOS 1.3 and 1.4,and android device can distinguish networt type mode.It seems a new feature for ffos.Please help push the solve process.
Thanks!

Updated

4 years ago
See Also: → bug 997071
(In reply to 孟宪茂 from comment #1)
> Hi peipei,
> 
> This issue exist in both FFOS 1.3 and 1.4,and android device can distinguish
> networt type mode.It seems a new feature for ffos.Please help push the solve
> process.
> Thanks!

xianmao, could you please attach the screenshot again? I don't understand what's the issue here.
My test result is:
after disable "Automatic selection", the network operators in area seach result shows: "UNICOM(Connected)" and "CMCC(Forbidden)". This should be acceptable.

could you please explain what result you expect?
Flags: needinfo?(xianmao.meng)
(Reporter)

Comment 3

4 years ago
(In reply to pcheng from comment #2)
> (In reply to 孟宪茂 from comment #1)
> > Hi peipei,
> > 
> > This issue exist in both FFOS 1.3 and 1.4,and android device can distinguish
> > networt type mode.It seems a new feature for ffos.Please help push the solve
> > process.
> > Thanks!
> 
> xianmao, could you please attach the screenshot again? I don't understand
> what's the issue here.
> My test result is:
> after disable "Automatic selection", the network operators in area seach
> result shows: "UNICOM(Connected)" and "CMCC(Forbidden)". This should be
> acceptable.
> 
> could you please explain what result you expect?

Hi,peipei

When the operator support 2G and 3G network type,the search result will have two network types,like my attachment(network type screenshot.bmp),it show two "DOLPHIN" items.They represent two type of networks,and should be distinguished,rather then just display two same operator names.It should show "DOLPHIN 2G","DOLPHIN 3G"like android devices.
Thanks!
Flags: needinfo?(xianmao.meng)
(Reporter)

Comment 4

4 years ago
Created attachment 8444304 [details]
network_type_screenshot.bmp
Arthur and Shawn, can you confirm if this is the current design as expected or if this is incorrect behaviour observed?
Flags: needinfo?(sku)
Flags: needinfo?(arthur.chen)
This is the current design. We don't show the operator types.
Flags: needinfo?(arthur.chen)

Comment 7

4 years ago
AOSP do not define this attribute regarding RAT (Radio Access Technology) even it can be supported by OEM/ODM's ril.

/**
* RIL_REQUEST_QUERY_AVAILABLE_NETWORKS
*
* Scans for available networks
*
* "data" is NULL
* "response" is const char ** that should be an array of n*4 strings, where
* n is the number of available networks
* For each available network:
*
* ((const char **)response)[n+0] is long alpha ONS or EONS
* ((const char **)response)[n+1] is short alpha ONS or EONS
* ((const char **)response)[n+2] is 5 or 6 digit numeric code (MCC + MNC)
* ((const char **)response)[n+3] is a string value of the status:
* "unknown"
* "available"
* "current"
* "forbidden"
*
* This request must not respond until the new operator is selected
* and registered
*
* Valid errors:
* SUCCESS
* RADIO_NOT_AVAILABLE
* GENERIC_FAILURE
*
*/
#define RIL_REQUEST_QUERY_AVAILABLE_NETWORKS 48

[1] - https://github.com/android/platform_hardware_ril/blob/master/include/telephony/ril.h#L2210
Flags: needinfo?(sku)
This works per design and not a bug. Minus for now unless this is deemed to be a bigger issue, then re-nom.
blocking-b2g: 1.4? → -

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 997071
You need to log in before you can comment on or make changes to this bug.