[Sora]Voice call timer isn't OK when receiving the second call

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
P1
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(b2g-master verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created an attachment (id=816221)
 SS
 
 DEFECT DESCRIPTION:
 When receiving the second voice call, phone presents the voice call timer above phone number string
 
  REPRODUCING PROCEDURES:
 0. Change the language to Brazilian(pt-BR);
 1. Place a voice call;
 2. Keep this call active;
 3. While engaged in the voice call, receive another voice call;
 4. Notice the timer of voice call;
 5. Check the information in presented above the phone number in screen.
 
  EXPECTED BEHAVIOUR:
 The timer of voice call must be presented properly and do not stay above phone number
 
 -Decrease the front size of timer or phone number;
 or
 -Displace the timer a lill bit to right.
 
  ASSOCIATE SPECIFICATION:
 None
 
  TEST PLAN REFERENCE:
 None
 
  TOOLS AND PLATFORMS USED:
 None
 
  USER IMPACT:
 Will see when receiving the 2nd voice call
 
  REPRODUCING RATE:
 100%
 
  For FT PR, Please list reference mobile's behavior:
 None

Comment 1

4 years ago
Created attachment 8444290 [details]
2014-06-22-22-31-15.png

Comment 2

4 years ago
Hi Vance,

This issue also block in LATAM.
blocking-b2g: --- → 1.3?

Comment 3

4 years ago
With the device set to Brazilian language, this cannot be reproduced using 1.3 buri build:
Gecko-d13526d
Gaia-7f361e6

Please see screenshot attached. The timer is shown in a different way and so, the problem is not presented

Comment 4

4 years ago
Created attachment 8444355 [details]
2014-06-23-08-02-41.png
(In reply to Isabel Rios [:isabel_rios] from comment #3)
> With the device set to Brazilian language, this cannot be reproduced using
> 1.3 buri build:
> Gecko-d13526d
> Gaia-7f361e6
> 
> Please see screenshot attached. The timer is shown in a different way and
> so, the problem is not presented

Hi Isabel, one thing i notice that is the 2nd call you use to test is only 9 digit phone number, could you try to find a 12 digit phone number and verify this issue again?

Thanks

Vance
Flags: needinfo?(isabelrios)

Comment 6

4 years ago
Hi Vance,

Sure, attached the result trying with a 12 digit phone number. In this case, there is an ellipsis at the end, this way the overlap does not happen either.
Flags: needinfo?(isabelrios)

Comment 7

4 years ago
Created attachment 8444367 [details]
12 digit phone number
(In reply to Isabel Rios [:isabel_rios] from comment #6)
> Hi Vance,
> 
> Sure, attached the result trying with a 12 digit phone number. In this case,
> there is an ellipsis at the end, this way the overlap does not happen either.

Thanks a lot, Isabel!

Dear MingMing, could you help to verify again with the newest 1.3 Gaia build? De-nom first since we cannot reproduce

Thanks

Vance
Flags: needinfo?(zmm)

Comment 9

4 years ago
Dear Vance, please make sure your Gaia build includes the "Brazilian", if there is no Brazilian, it will get the English.

I get the pt-BR language package from http://hg.mozilla.org/gaia-l10n , the call duration is translated like this :

#Call duration units
callDurationMinutes={{ m }}min {{ s }}s
callDurationHours={{ h }}h {{ m }}min {{ s}}s
Flags: needinfo?(zmm)
(In reply to Mingming ZHAO from comment #9)
> Dear Vance, please make sure your Gaia build includes the "Brazilian", if
> there is no Brazilian, it will get the English.
> 
> I get the pt-BR language package from http://hg.mozilla.org/gaia-l10n , the
> call duration is translated like this :
> 
> #Call duration units
> callDurationMinutes={{ m }}min {{ s }}s
> callDurationHours={{ h }}h {{ m }}min {{ s}}s

Dear MingMing, that is master repo for localizations, please use https://hg.mozilla.org/releases/gaia-l10n/v1_3/ instead where you can find the strings for 1.3 as: {{ h }}:{{ m }}:{{ s}}

Isabel, could you please check the behaviour in master build with master localizations and provide feedback here if the issue is reproducible?
Flags: needinfo?(zmm)
Flags: needinfo?(isabelrios)

Comment 11

4 years ago
Please see screenshot attached after testing with today's (06/24) master buri build:
Gecko-fda21c3
Gaia-ed5231f

The ellipsis is also presented, so there is not any overlap.
Flags: needinfo?(isabelrios)

Comment 12

4 years ago
Created attachment 8445086 [details]
brazilian language master build
Per comment 8, removing the blocking nom.
blocking-b2g: 1.3? → ---

Updated

4 years ago
Flags: needinfo?(zmm)
Flags: needinfo?(jlorenzo)
Created attachment 8564188 [details]
Verification screenshot

Doesn't occur on the current master anymore.

Build ID               20150213010213
Gaia Revision          2a2b008f9ae957fe19ad540d233d86b5c0b6829e
Gaia Date              2015-02-12 07:44:13
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2f5c5ec1a24b
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150213.043439
Firmware Date          Fri Feb 13 04:34:49 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(jlorenzo)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-master: --- → verified
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.