[OPENC_1.3]import contacts from SIM card and from memory card,the result is different

RESOLVED DUPLICATE of bug 1026370

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 1026370
4 years ago
4 years ago

People

(Reporter: wangxiao, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8444310 [details]
2014-06-23-17-06-48.png

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1 (Beta/Release)
Build ID: 20110413222027

Steps to reproduce:

1.Contacts is empty.
2.SIM card have the same three contacts. 
{name:'aaa', phone:'123456'}
{name:'aaa', phone:'123456'}
{name:'aaa', phone:'123456'}
3.Memory card have the same three contacts. 


Actual results:

1.Keep Contacts is empty.
2.Click contacts application->settings->import contacts->SIM card.
3.After the importing success, the status show "Imported 3 contacts".
4.The end result is an increase of 3 contacts.

Another Step:
1.Keep Contacts is empty.
2.Click contacts application->settings->import contacts->Memory card.
3.After the importing success, the status show "Imported 3 contacts".
4.The end result is an increase of 1 contacts.




Expected results:

expected results:
After the importing success, the status show "Imported 1 contacts" and the end result is an increase of 1 contacts.
(Reporter)

Comment 1

4 years ago
I find the infomation of Bug 1026369,Bug 1028106,and Bug 1021548. I try to add the patch code in contacts_matcher.js and import_sim_contacts.js. But the above problems is still reproduce,and that the status prompt "Imported 3 contacts" disappeared.
blocking-b2g: --- → 1.3?
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
This will not be a 1.3 blocker.
blocking-b2g: 1.3? → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1026370
(Reporter)

Comment 4

4 years ago
Created attachment 8448579 [details]
2014-07-01-15-49-15.png
(Reporter)

Comment 5

4 years ago
Dear all,
I tried to add the following code based bug 1021548, bug 1026369,  bug 1026370 and bug 977528.
Below is a list of the relevant address:
https://github.com/mozilla-b2g/gaia/commit/7edc43f1eecefa612fc28f0982c55a2bd16555e4
https://github.com/mozilla-b2g/gaia/commit/0ad31893b31fbe8fdc3c8bb221810f4f877a74c6
https://github.com/mozilla-b2g/gaia/commit/d283b742a12ac43ec087f45b02d3817cf7ddab69

Now the result is:(b2g-1.3)

Steps to reproduce:
1.Contacts is empty.
2.SIM card have the same three contacts. 
{name:'aaa', phone:'123456'}
{name:'aaa', phone:'123456'}
{name:'aaa', phone:'123456'}
3.Memory card have the same three contacts. 

Actual results:
1.Keep Contacts is empty.
2.Click contacts application->settings->import contacts->SIM card.
3.After the importing success, the status show "Imported 3 contacts".
4.The end result is still an increase of 3 contacts.

Another Step:
1.Keep Contacts is empty.
2.Click contacts application->settings->import contacts->Memory card.
3.The screentip is "Could not import contacts from memory card".
(The attachment 2014 [details]-07-01-15-49-15.png is the screenshot)
Flags: needinfo?(vchen)
You need to log in before you can comment on or make changes to this bug.