If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot replace search engine

RESOLVED INVALID

Status

()

Firefox
Search
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: Yajo, Unassigned)

Tracking

30 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140611060104

Steps to reproduce:

I wanted to use duckduckgo search engine (from https://duckduckgo.com/opensearch.xml) because it has now autocompletion and default Firefox DDG engine plugin does not have it.

So, I went to duckduckgo.com > use on Firefox > OK.


Actual results:

Error: Firefox could not install search plugin from "https://duckduckgo.com/opensearch.xml" because a search plugin with the same name already exists.


Expected results:

Prompt me to replace it.

Note: If I delete FF's default DDG search plugin, I still get the same error!

Workaround: https://duck.co/forum/comment/34888
Hi,

I tried to reproduce it with lastest Nightly Firefox/33.0 ID:20140623030201 on Debian (Linux x86_64).
Initially I  got the "Error: Firefox could not install search plugin from "https://duckduckgo.com/opensearch.xml" because a search plugin with the same name already exists." message as well (I had installed the DDG plus plugin from https://addons.mozilla.org/en-US/firefox/addon/duckduckgo-for-firefox/ a while ago).

I then removed DuckDuckGo from the "Manage Search Engines" list (click on the dropdown menu in the search field, select "Manage Search Engines", select DuckDuckGo and then click "Remove"), reload duckduckgo.com page, clicked again on "Use on Firefox" and the plugin was correctly installed.


I remember having seen a similar bug report: Bug 987516 (see comment 3). Still not sure if this one is a duplicate, though. Seems there's something wrong in the way the adding/removal of this particular plugin is handled, but the problem is not always reproducible.

Out of curiosity: are you using a vanilla version of Firefox (ie downloaded directly from the mozilla website) or a packaged version from a Linux distro? And if so, which distro are you using?

Thanks,
Francesca
Flags: needinfo?(yajo.sk8)
(Reporter)

Comment 2

3 years ago
(In reply to Francesca Ciceri [:madamezou] from comment #1)
> I tried to reproduce it with lastest Nightly Firefox/33.0 ID:20140623030201
> on Debian (Linux x86_64).
> Initially I  got the "Error: Firefox could not install search plugin from
> "https://duckduckgo.com/opensearch.xml" because a search plugin with the
> same name already exists." message as well (I had installed the DDG plus
> plugin from
> https://addons.mozilla.org/en-US/firefox/addon/duckduckgo-for-firefox/ a
> while ago).
> 
> I then removed DuckDuckGo from the "Manage Search Engines" list (click on
> the dropdown menu in the search field, select "Manage Search Engines",
> select DuckDuckGo and then click "Remove"), reload duckduckgo.com page,
> clicked again on "Use on Firefox" and the plugin was correctly installed.

I never used that plugin. The conflict is with FF's default DDG search plugin. Why don't you try with a new profile? Maybe then you will reproduce the bug.

> I remember having seen a similar bug report: Bug 987516 (see comment 3).
> Still not sure if this one is a duplicate, though. Seems there's something
> wrong in the way the adding/removal of this particular plugin is handled,
> but the problem is not always reproducible.

Seems related, at least that comment. However I'm not sure if it's the same because the plugin I'm trying to install is at https://duckduckgo.com/opensearch.xml, while that bug is also about a full plugin.

> Out of curiosity: are you using a vanilla version of Firefox (ie downloaded
> directly from the mozilla website) or a packaged version from a Linux
> distro? And if so, which distro are you using?

I'm using FF 30 from Fedora 20.

You can also see the full thread for the workaround I told you here: https://duck.co/forum/thread/5313/can-t-load-firefox-search-box-add-on
Flags: needinfo?(yajo.sk8)

Updated

3 years ago
QA Whiteboard: [bugday-20140630]
Component: Untriaged → Search
(In reply to Yajo from comment #2)
> 
> I never used that plugin. The conflict is with FF's default DDG search
> plugin. Why don't you try with a new profile? Maybe then you will reproduce
> the bug.


Uhm, I've tried with a new profile and I don't have DDG search among the default plugins. On Nightly Firefox/33.0 ID:20140707030202 with a clean profile I only have these among the default search plugins:
- Google
- Yahoo
- Bing
- Amazon.com
- Ebay
- Twitter
- Wikipedia (en)

[...]
> 
> I'm using FF 30 from Fedora 20.

And this explains the different default search engines: apparently the Fedora packaging team added a patch to have DDG as default search engine, see http://pkgs.fedoraproject.org/cgit/firefox.git/tree/firefox-duckduckgo.patch

I think at this point that the best course of action is to open a bug report against the Fedora Firefox version, since this seems to concerns their patch and not Firefox itself.
For this reason, I'm closing this now as Invalid, feel free to reopen if the problem presents itself with a vanilla Firefox or if I've misunderstood the situation.

Cheers,
Francesca
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [bugday-20140630] → [bugday-20140630] [bugday-2014-07-07]
Resolution: --- → INVALID

Comment 4

2 years ago
Reopened with proposed solution at https://bugzilla.mozilla.org/show_bug.cgi?id=1184475

With the upgrading of some search add-ons, this remains a bug.
You need to log in before you can comment on or make changes to this bug.