Closed Bug 1028926 Opened 8 years ago Closed 8 years ago

crash in java.lang.ClassCastException: org.mozilla.gecko.tabspanel.PrivateTabsPanel cannot be cast to org.mozilla.gecko.tabspanel.TabsPanel$CloseAllPanelView at org.mozilla.gecko.tabspanel.TabsPanel.onMenuItemClick(TabsPanel.java)

Categories

(Firefox for Android Graveyard :: General, defect)

33 Branch
All
Android
defect
Not set
critical

Tracking

(firefox33 affected)

RESOLVED DUPLICATE of bug 1028337
Tracking Status
firefox33 --- affected

People

(Reporter: aaronmt, Assigned: Margaret)

References

Details

(Keywords: crash, reproducible)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-c7cab5f9-46e4-4e70-a436-206772140620.
=============================================================

java.lang.ClassCastException: org.mozilla.gecko.tabspanel.PrivateTabsPanel cannot be cast to org.mozilla.gecko.tabspanel.TabsPanel$CloseAllPanelView
	at org.mozilla.gecko.tabspanel.TabsPanel.onMenuItemClick(TabsPanel.java:231)
	at org.mozilla.gecko.widget.GeckoPopupMenu.onMenuItemClick(GeckoPopupMenu.java:153)
	at org.mozilla.gecko.menu.GeckoMenu.handleMenuItemClick(GeckoMenu.java:575)
	at org.mozilla.gecko.menu.GeckoMenu.onItemClick(GeckoMenu.java:551)
	at android.widget.AdapterView.performItemClick(AdapterView.java:298)
	at android.widget.AbsListView.performItemClick(AbsListView.java:1100)
	at android.widget.AbsListView$PerformClick.run(AbsListView.java:2749)
	at android.widget.AbsListView$1.run(AbsListView.java:3423)
	at android.os.Handler.handleCallback(Handler.java:725)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:5041)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:793)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:560)
	at dalvik.system.NativeStart.main(Native Method)

Comments:

* Close all tabs on private tab screen
* Open few tabs, then open private tab and click on the new "Close all tabs"
Reproducible by tapping close all private tabs with no private tabs open.

--
Nightly (06/23)
Keywords: reproducible
Duplicate of this bug: 1028923
Will be fixed in bug 1028337.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1028337
tracking-fennec: ? → ---
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.