Link toolbar doesn't support HTTP links headers

RESOLVED WONTFIX

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED WONTFIX
17 years ago
4 years ago

People

(Reporter: Hixie (not reading bugmail), Unassigned)

Tracking

({testcase})

Trunk
testcase
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P4], URL)

(Reporter)

Description

17 years ago
STEPS TO REPRODUCE
   Go to a web page with links in HTTP headers, e.g.:
      http://www.bath.ac.uk/~py8ieh/internet/eviltests/link6.html

ACTUAL RESULTS
   The link toolbar has no links.

EXPECTED RESULTS
   Identical to http://www.bath.ac.uk/~py8ieh/internet/eviltests/link2.html

cc'ing usual suspects as per bug 102832.
(Reporter)

Updated

17 years ago
Blocks: 7954
Depends on: 102906
Keywords: testcase
Whiteboard: [Hixie-P4]
Could you confirm Link is in HTTP 1.1 (RFC 2616)? As far as I can see, it
appears to be deprecated.

Gerv

Comment 2

17 years ago
Link was dropped from the final version of RFC 2616:

   The Alternates, Content-Version, Derived-From, Link, URI, Public and
   Content-Base header fields were defined in previous versions of this
   specification, but not commonly implemented. See RFC 2068 [33].

This bug should be WONTFIX until someone demonstrates why it should be implemented.
Severity: normal → enhancement
(Reporter)

Comment 3

17 years ago
It was taken out of the final spec because there were no implementations. If
people implement it, it will be put back in.

HTTP Link headers are an amazingly powerful feature. We support them for
stylesheets, making it possible to style an entire website without touching a
single file outside the server configuration. Similarly, supporting Link for the
link toolbar would give the same power for linking.

Having half-hearted Link header support (e.g. for stylesheets but not links) is
almost worse than having no support, as it is inconsistent and confusing. Link
headers are good. Why would we _not_ want to support them?
Blocks: 103053
QA Contact: sairuh → claudius

Comment 4

17 years ago
Adding 'headers' to the description - the previous description sounded like the
link toolbar didn't support http links as in URL's that beging with http://.
Summary: Link toolbar doesn't support HTTP links → Link toolbar doesn't support HTTP links headers
This is also the only way to support LINK-type structures in non-(X)HTML 
documents.

Updated

15 years ago
Assignee: drbrain-bugzilla → guifeatures
OS: Windows 2000 → All
Hardware: PC → All

Updated

14 years ago
Blocks: 102906
No longer depends on: 102906
Product: Core → Mozilla Application Suite
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: claudius → guifeatures

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design

Comment 7

8 years ago
The SeaMonkey team won't devote any resources on this. Closing as WONTFIX
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.