Right clicking link toolbar buttons activates them

VERIFIED FIXED in mozilla0.9.5

Status

VERIFIED FIXED
17 years ago
11 years ago

People

(Reporter: ian, Assigned: jwbaker)

Tracking

({testcase})

Trunk
mozilla0.9.5
x86
Windows 2000
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
STEPS TO REPRODUCE
   http://www.bath.ac.uk/~py8ieh/internet/eviltests/link2.html
   Right click on a link button (e.g. Next) on the link toolbar.

ACTUAL RESULTS
   The link is activated.

EXPECTED RESULTS
   Nothing should happen (or, a context menu should appear).

cc'ing usual suspects as per bug 102832.
(Assignee)

Comment 1

17 years ago
Here's a simple patch that only listens to the primary click.
Assignee: drbrain-bugzilla → jwbaker
Keywords: patch, review
Target Milestone: --- → mozilla0.9.5
(Assignee)

Comment 2

17 years ago
Created attachment 51882 [details] [diff] [review]
Patch to only handle primary click
(Reporter)

Comment 3

17 years ago
That was quick! :-)
Keywords: testcase
Comment on attachment 51882 [details] [diff] [review]
Patch to only handle primary click

r=gerv.
Attachment #51882 - Flags: review+
QA Contact: sairuh → claudius
(Assignee)

Comment 5

17 years ago
I don't check in so someone else better take this one and run with it.
This one-line fix found its way in as part of bug 102832.

Gerv
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.