Closed Bug 1029143 (e10sa11y2) Opened 6 years ago Closed 2 years ago

Implement accessibility for sandboxed e10s.

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s + ---

People

(Reporter: davidb, Unassigned)

References

(Depends on 6 open bugs)

Details

(Keywords: dogfood, meta)

This bug organizes work for sandboxed e10s. (Old e10s-only approach was now-obsolete bug 646596)
Blocks: core-e10s
tracking-e10s: --- → ?
Keywords: meta
Depends on: 1046407
No longer depends on: 1046407
Duplicate of this bug: 1046407
Adding "dogfood" keyword so this bug shows up on the e10s wiki's list of known issues:

https://wiki.mozilla.org/Electrolysis#Known_Issues
Keywords: dogfood
Getting this into the last aurora blocking milestone so we can track. All the work here probably doesn't block our uplift.. we can adjust as dep bugs get filed.
Depends on: 1108607
Depends on: 1107338
Depends on: 1107337
Depends on: 1107334
No longer depends on: 1055508
Depends on: 1109891
Depends on: 1110510
Depends on: 1113389
Depends on: 1113407
Depends on: 1113845
Depends on: 1119923
Depends on: 1121182
Depends on: 1124449
Depends on: 1124821
Depends on: 1127402
Depends on: 1128751
Depends on: 1132134
Depends on: 1134547
Depends on: 1146797
Depends on: 1151402
Depends on: 1156964
Depends on: 1159326
No longer depends on: 1066901
No longer depends on: 1096834
No longer depends on: 1108607
Depends on: 1129215
Depends on: 1163988
Depends on: 1111541
No longer depends on: 1111541
Depends on: 1185065
Depends on: 1170049
Depends on: 1189277
Depends on: 1195940
Depends on: 1209615
Depends on: 1210549
Depends on: 1210741
Depends on: 1218762
Depends on: 1227124
Depends on: 1232416
is this related to accessibility.ipc_architecture.enabled which more or less negates all the work so far in making firefox multiprocess?

since updating, my usual tab session has gone from having around 600MB in firefox.exe to bloating well past 1.5GB and taking forever to restore to the point of popping up hung script dialogues (unless i disable accessibility.ipc_architecture.enabled)
Depends on: 1198383
Depends on: 1258839
Depends on: 1265549
Depends on: 1270916
Depends on: 1272336
Depends on: 1272146
No longer depends on: 1272146
Depends on: 1272146
Depends on: 1272491
Depends on: 1272706
Depends on: 1272712
Depends on: 1272268
Depends on: 1226473
Flags: needinfo?(dbolter)
Assignee: tbsaunde+mozbugs → nobody
I think this meta has served it's purpose - please reopen if needed.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(dbolter)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.