Closed Bug 1029145 Opened 7 years ago Closed 6 years ago

[B2G][Notification]Notifications do not clear from the status bar when the related app is behind the lockscreen.

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 fixed, b2g-v2.1 verified)

RESOLVED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- fixed
b2g-v2.1 --- verified

People

(Reporter: dharris, Assigned: mnjul)

References

()

Details

(Keywords: regression, Whiteboard: [2.0-flame-test-run-2] [p=1])

Attachments

(3 files)

Attached file Notification Logcat
Description:
A notification received while the phone is locked inside the related app, will not clear from the status bar naturally.   The notification icon will only clear once another notification occurs.

Perequsites:
1) Have an SMS conversation available with another available device.
2) Clear all notifications for clarity

Repro Steps:
1) Update a Flame to 20140620000202
2) Open the SMS app and navigate to the conversation from the prerequisite.
3) Lock the phone.
4) From the other device send an SMS to the DUT.
5) Unlock the phone.
6) Note that the notification icon still shows an unread notification.
7) Open the Notification Tray and note that there is no notification.
8) Close the Notification Tray and note that the notification icon still shows 1 notification.

Actual:
The notification icon does not update properly when coming back to an app from the lockscreen.

Expected:
The notification for that event is cleared.

Flame 2.0

Environmental Variables:
Device: Flame 2.0
Build ID: 20140623000201
Gaia: 729f214b887ce8efe7d870145d31acb2c6427817
Gecko: 117ba3eda4d2
Version: 32.0a2 (2.0) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/9271/
See attached: Logcat, Video - http://youtu.be/HCb75tqVQyM
This issue DOES reproduce on Flame 2.1, Open C 2.1, and Open C 2.0

The status bar receives an unread message icon when unlocking the phone into the message thread

Flame 2.1

Environmental Variables:
Device: Flame Master
Build ID: 20140623040202
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 366b5c0c02d3
Version: 33.0a1 (Master) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Open_C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140623040202
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 366b5c0c02d3
Version: 33.0a1 (Master)  
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Open_C 2.0

Environmental Variables:
Device: Open C 2.0
Build ID: 20140623000201
Gaia: 729f214b887ce8efe7d870145d31acb2c6427817
Gecko: 117ba3eda4d2
Version: 32.0a2 (2.0)  
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
_________________________________________________________________________________________

This issue does NOT reproduce on Buri 2.1, Buri 2.0, Flame 1.4, Buri 1.4 or Open C 1.4

The status bar does not receive an unread message icon on it, or a notification in the notification drop down when unlocking the phone into the message thread


Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140623073039
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 335b6610fe0c
Version: 33.0a1 (Master) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0


Buri 2.0

Environmental Variables:
Device: Buri 2.0
BuildID: 20140623063006
Gaia: 84ca0fe0a86d039f6d99cb562f52ef55045dee1d
Gecko: cef223bae66b
Version: 32.0a2 (2.0) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 1.4

Environmental Variables:
Device: Buri 1.4
BuildID: 20140623063003
Gaia: 3419a1f68aaf64a0688685bce42d4173b6125597
Gecko: ccf2fada2574
Version: 30.0 (1.4) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140623000201
Gaia: 3419a1f68aaf64a0688685bce42d4173b6125597
Gecko: 34ecc9af3560
Version: 30.0 (1.4) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Open_C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140623000201
Gaia: 3419a1f68aaf64a0688685bce42d4173b6125597
Gecko: 34ecc9af3560
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
I found that this bug was resolved fixed on 3/20 for 2.0 based on comment number 14 here: https://bugzilla.mozilla.org/show_bug.cgi?id=981401#c14
Nominating this 2.0? since this is a regression. This will cause confusion to the end user since the status bar will indicate that there is a notification even though there is not an actual notification present.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: jmercado
blocking-b2g: 2.0? → 2.0+
B2g-inbound Regression Window

Last working 
Environmental Variables:
Device: Flame Master
BuildID: 20140603023003
Gaia: 969d35114eed0eabbd0fe7c01fad19a2df0097b5
Gecko: 8b3454b9896d
Version: 32.0a1 (Master) 
Firmware Version: v122


First Broken 
Environmental Variables:
Device: Flame Master
BuildID: 20140603053003
Gaia: cdaf998934f4924a4b256ed5458b484818a01948
Gecko: 7fba4f8ca783
Version: 32.0a1 (Master) 
Firmware Version: v122

Last working gaia / First broken gecko - Issue does NOT occur
Gaia: 969d35114eed0eabbd0fe7c01fad19a2df0097b5
Gecko: 7fba4f8ca783

First broken gaia / Last working gekko - Issue DOES occur
Gaia: cdaf998934f4924a4b256ed5458b484818a01948
Gecko: 8b3454b9896d

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/969d35114eed0eabbd0fe7c01fad19a2df0097b5...cdaf998934f4924a4b256ed5458b484818a01948
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Broken by bug 950884.

John - Can you take a look?
Blocks: 950884
Component: Gaia::SMS → Gaia::System
Flags: needinfo?(jlu)
Confirmed bug 950884 broke it and the bug is reproducible on current master. Investigating.
Flags: needinfo?(jlu)
Whiteboard: [2.0-flame-test-run-2] → [2.0-flame-test-run-2] [p=1]
Target Milestone: --- → 2.0 S5 (4july)
Comment on attachment 8446329 [details] [review]
Patch (PR @ Github)

Tim, could you review this patch for me? The issue is actually a simple JS logic error: in the old codes, when lockScreenNotificationNode was removed from DOM tree, we could no longer access its parent with lockScreenNotificationNode.parentNode .
Attachment #8446329 - Attachment description: WIP Patch (PR @ Github) → Patch (PR @ Github)
Attachment #8446329 - Flags: review?(timdream)
Attachment #8446329 - Flags: review?(timdream) → review+
Is this part of code protected by tests?
Assignee: nobody → jlu
Status: NEW → ASSIGNED
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #9)
> Is this part of code protected by tests?

Eek, not currently. Will be at bug 1031251.
Master: https://github.com/mozilla-b2g/gaia/commit/104a835e69f32c6c3cc832160fa73c8218836a57
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Attached video VIDEO0159_Compress.MP4
This issue has been successfully verified on Flame 2.1:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
Status: RESOLVED → VERIFIED
Status: VERIFIED → RESOLVED
Closed: 7 years ago6 years ago
You need to log in before you can comment on or make changes to this bug.