[B2G][2.0][Flame][Smart Collections] Missing Star Button (bookmark) on Smart Collection App

VERIFIED FIXED in Firefox OS v2.0

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ychung, Assigned: crdlc)

Tracking

({regression})

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [2.0-flame-test-run-2][systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8444726 [details]
logcat_20140623_NoStar.txt

Description: 
When the user scrolls down to the bottom of a Smart Collection app, the star button is missing on the menu bar. The user is unable to add the app to the home screen.

Repro Steps:
1) Update a Flame to 20140623000201.
2) Select any Smart Collection from the homescreen.
3) Select a non-certified app.
4) Scroll down at the bottom of the page.
5) Verify the menu bar displays the star button (bookmark) correctly.

Actual:
There is no star button. The user is unable to add the app to the home screen.

Expected:
The star button is displayed. When selected, 'Add to Home Screen' dialog is displayed.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140623000201
Gaia: 729f214b887ce8efe7d870145d31acb2c6427817
Gecko: 117ba3eda4d2
Version: 32.0a2 (2.0)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/5856/
See attached: screenshot, logcat
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(ktucker)
(Reporter)

Comment 1

4 years ago
Created attachment 8444731 [details]
NoStarButtonOnSmartCollectionApps.png

This issue DOES reproduce on Flame 2.1, Buri 2.1, Open C 2.1, Buri 2.0, and Open C 2.0:

Flame 2.1

Environmental Variables:
Device: Flame Master
Build ID: 20140623040202
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 366b5c0c02d3
Version: 33.0a1 (Master)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0 

Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140623073039
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 335b6610fe0c
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0 

Open C 2.1

Environmental Variables:
Device: Open_C Master
Build ID: 20140623040202
Gaia: bd5065ced020014df5fd45259fba1ac32d65673b
Gecko: 366b5c0c02d3
Version: 33.0a1 (Master)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140623063006
Gaia: 84ca0fe0a86d039f6d99cb562f52ef55045dee1d
Gecko: cef223bae66b
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 

Open C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140623000201
Gaia: 729f214b887ce8efe7d870145d31acb2c6427817
Gecko: 117ba3eda4d2
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 


There is no star button. The user is unable to add the app to the home screen.

=============================================================================

This issue does NOT reproduce on Flame 1.4, Buri 1.4 or Open C 1.4

Flame 1.4

Environmental Variables:
Device: Flame 1.4
Build ID: 20140623000201
Gaia: 3419a1f68aaf64a0688685bce42d4173b6125597
Gecko: 34ecc9af3560
Version: 30.0 (1.4)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0 

Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140623063003
Gaia: 3419a1f68aaf64a0688685bce42d4173b6125597
Gecko: ccf2fada2574
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 1.4

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140623000201
Gaia: 3419a1f68aaf64a0688685bce42d4173b6125597
Gecko: 34ecc9af3560
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


The star button is displayed as expected.
Nominating this 2.0? since this is a regression. It is also inconsistent behavior since the user can star apps found using the main e.me search but cannot star apps from collections.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression, regressionwindow-wanted
QA Contact: jmitchell
I won't have this regression window until tomorrow but for the sake of timely information all indications point to this being broken on the first build where vertical homescreen was implemented as the default.

Updated

4 years ago
Blocks: 1015336
blocking-b2g: 2.0? → 2.0+
Component: Gaia::Settings → Gaia::System
Whiteboard: [2.0-flame-test-run-2] → [2.0-flame-test-run-2][systemsfe]

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
(Assignee)

Updated

4 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 4

4 years ago
Created attachment 8445021 [details]
Github pull request

Thanks Ran
Attachment #8445021 - Flags: review?(ran)
Comment on attachment 8445021 [details]
Github pull request

Looking good :)
Attachment #8445021 - Flags: review?(ran) → review+
Attachment already approved - appears regression window is no longer needed so I'm removing it.
Status: ASSIGNED → NEW
blocking-b2g: 2.0+ → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+] → [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage+]
Component: Gaia::System → Gaia::Settings
Keywords: regressionwindow-wanted
Woah there... I seemed to have set the blocking flag back to ? (sorry about that) and don't have the authority / ability to fix that back up to +.

I'll be more careful about refreshing my page before modifying and saving.

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage+] → [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage+][lead-review+]
Target Milestone: --- → 2.0 S5 (4july)
(Assignee)

Comment 8

4 years ago
Merged in master:

https://github.com/crdlc/gaia/commit/8900e83cf9fa6ff0970c725aef5f53c245dc6415
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
status-b2g-v2.1: affected → fixed

Comment 10

4 years ago
This issue has been verified successfully on Flame2.0&2.1
Verify video:"verify_1029167.mp4".
**Flame2.1 is not support star fuction.

Flame2.0 build
Gaia-Rev        856863962362030174bae4e03d59c3ebbc182473
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e40fe21e37f1
Build-ID        20141208000206
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141208.035628
FW-Date         Mon Dec  8 03:56:38 EST 2014
Bootloader      L1TC00011880

Flame 2.1 build:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141205.035305
FW-Date         Fri Dec  5 03:53:16 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified

Comment 11

4 years ago
Created attachment 8533542 [details]
Verified video: verify_1029167.MP4

In the video that is Flame2.1 on the left Flame2.0 on the right.
Flaem2.1->left   Flame2.0->right
You need to log in before you can comment on or make changes to this bug.